Theme not validating, Cornerstone has no validation option

Our theme stopped working, Cornerstone is not working either, and the editor is breaking our Javascript by adding “br” tags in our code blocks. When we try to re-add the API key for X-theme it gives “Connection error” so we used the work-around Which seems to work but the problems remain and we can’t repair or update Cornerstone. On Cornerstone > Home it has no option to Validate. We tried re-installing the plugin for x-theme already.
Here is a screenshot of X Addon > Product Validation:
Here we can see Cornerstone > Home with no option to validate (I’ve zoomed out to fit everything):

Hello Matt,

If you are still seeing X Addons in the admin area, it means that you are using an older version of X which has a different validation process from the current one. Because of this, you will have to manually update X then validate the theme after.

Please check this link for instructions under Manual X Update Via FTP:

Hope this helps.

thanks for the reply. I tried using the method described above and I can see the theme is updated now, but it still will not accept my purchase code. Now when I insert the code and hit enter it just redirects to a blank page, when I return to the dashboard it says X is not validated.

Hi Matt,

I’m sorry to hear that you’re still having validation issue. We also have troubleshooting guide available here ( Most possible causes are due to PHP cURL or firewall related which you need to check.

If you’re still having issues, could you please provide us with your WordPress login credentials in a secure note to check your issue further.


Hi Matt,

Thank you for the information provided. Your issue was that, you’re using an older version of Cornerstone plugin so that our validation process will not initiate correctly.

I have re-installed the latest version of Cornerstone plugin and then I was able to validate your site.


Thank you very much for your help. Unfortunately I am still having the original issue. When I edit a page ‘br’ tags are getting injected in my javascript code and breaking it. I can’t edit them in Cornerstone because, when I open the pages in cornerstone now, all the content is missing.

Hi Matt,

Can you point us where you have added your javascript and the url of the page where we can see the issue.

For the mean time You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

To be able to edit your pages, you can try rolling it back to previous revision when it is still editable


I use this page to test it’s published privately. You will see that if you change the title or any text, or anything. Suddenly a br tag appears inside the javascript that is embedding the video, and if you visit the page again you will see no video and a console error. Feel free to play with that page as it’s a private clone of another page.
Even restoring a revision, then editing it will cause the same issue. It’s only when the pages are untouched or first restored from a revision that they don’t break

Hey Matt,

It is WordPress’ auto paragraph feature that is adding those br tags and not X nor Cornerstone. When you edit a page in the default WordPress editor, WordPress will automatically add p and br tags where sees fit even if the user does not intend them to be added.

We can’t stop this feature so if you’re not going to use Cornerstone, you will need to remove the new line spaces in your code. You can do that in HTML minification tools like

When you said:

You most likely cloned the page like you did with the private page. Cornerstone’s builder data is specific per page and could be be included in the cloned page that is why you get a blank Cornerstone page.

When duplicating a page, it’s best to save your page as a template. Please see Saving Templates instruction at

Hope that helps.

Thanks for the reply, but I can’t edit any of my pages in Cornerstone, including ones that were definitely made with Cornerstone like the landing page. Also I don’t have this issue on my other sites that use different themes, and the problems seemed to start at the same time as the other validation issues.

Hi Matt,

It looks like your site is under CloudFlare, please log in to CloudFlare dashboard and do the following:

First exclude the Cornerstone builder from being cache by using this pattern ** follow this article on how you can add a page rule (exclude) on your CloudFlare account.

Next disable the CloudFlare’s JS and CSS minification option, read this article., X theme JS and CSS files are already minified so you don’t need this feature (this is actually the feature that is causing the issue, breaking the CSS files.)

Lastly purge everything from the cache, also clear your browser’s cache to make sure that there is no cache involve when you load your pages.

Another thing, please update the X extensions (X – Content Dock, X – Custom 404, and X – Under Construction).

To update the Extensions to the version that is supported by the theme:

- Ensure your theme is validated so Extensions can be installed automatically
- Deactivate and delete the extensions, from the plugins panel.
- On the X > Validation > Extensions locate and install the extensions that you need.
- Visit "Plugins" panel in your Dashboard to activate the newly installed version.

Because all of the plugin settings are stored in the database, and because version 2.x will migrate settings from older versions, its safe to use this method of deleting the previous version. But always keep a backup of your entire site just to be safe.

Let us know how it goes,

Thanks so much for the reply. We’ve tried

  1. setting a cloudflare rule to avoid cacheing /x/
  2. clearing the cloudflare cache
  3. running in incognito mode
  4. we checked and minify is off. there is also no minify in htaccess.
  5. we tried disabling and enabling all plugins.
    It is still not working. We did notice that the editor on this specific page is working We don’t know why this is.

Hi Matt,

Looks like it’s edited outside, the issue is not the builder but the data/content are corrupted. Have you done some database editing before like URL replacement? For that, a site wide restoration is recommended so the data are still intact then just update the theme and cornerstone again. Unfortunately, I’m not sure to which date it should be restored, it would be a trial and error.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.