The preview could not open due to iframe response being incomplete

Hey Alex,

The message in the console points to Cloudflare. Would you mind disconnecting your site from Cloudflare temporarily to test if it’s causing the issue?


Cloudflare deactivated, issue is still there.

Hi @al2code,

I’ve checked your site and have some more information about what is going on here. Anytime WordPress finishes running a request, it fires a hook called shutdown. This should always happen after the closing HTML tag. When the preview frame loads, we output a signal that looks like CORNERSTONE_FRAME to indicate that the preview reached the end without any unexpected failures. Our system expects to see this:


On your site, it looks like this:

CORNERSTONE_FRAME<script type='text/javascript' style='display:none;' async>

<script type="text/javascript" data-cfasync="false"></script></body></html>

Something on your server is rewriting the HTML, and it confuses the builder live preview. That extra code doesn’t seem to do anything either. I tried some testing with plugins off as well and had the same results. Oddly, that code doesn’t seem to even do anything at all so I’m not sure why it would be added.

Are you aware of anything on the server that could be rewriting the HTML? If not, from here I would recommend checking with your host to see if they can uncover why that is outputting.

I see, thank you for looking into it, unfortunately I don’t know anything that can cause the issue, the website was working perfectly and suddenly it stopped.
To be honest I am not sure what to do next, since I tried everything. What can rewrite HTML?

This is how my .htaccess looks like.

BEGIN WordPress

The directives (lines) between “BEGIN WordPress” and “END WordPress” are

dynamically generated, and should only be modified via WordPress filters.

Any changes to the directives between these markers will be overwritten.

RewriteEngine On RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}] RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

END WordPress

Contacted the hosting providers, they looked into everything and they said everything looks good on their side.
This is the error log:
[Tue Apr 06 20:09:12.833142 2021] [autoindex:error] [pid 26685:tid 139910044419840] [client] AH01276: Cannot serve directory /home/ No matching DirectoryIndex (index.php,default.php,index.html,default.html) found, and server-generated directory index forbidden by Options directive [Tue Apr 06 19:30:31.196853 2021] [authz_core:error] [pid 26685:tid 139909230327552] [client] AH01630: client denied by server configuration: /home/, referer: [Tue Apr 06 19:30:31.196806 2021] [authz_core:error] [pid 26685:tid 139909230327552] [client] AH01630: client denied by server configuration: /home/, referer:

Hi @al2code,

You’ve seen this thread already but I was able to confirm it is the exact same problem: The preview could not load due to iframe response

It would be worth following along with that thread as well in case it helps.

Can you ask your host specifically if they can identify where this code is coming from?

<script type='text/javascript' style='display:none;' async>

<script type="text/javascript" data-cfasync="false"></script></body></html>

It always appears on the front end of the site. It doesn’t come from the theme, and doesn’t come from any plugins. So it must be coming from either WordPress being modified, or some layer of server configuration.

From hosting “Issue seems to be in the files wp-content/themes/pro/default.php & wp-content/themes/pro/index.php but I am unable to locate the code unfortunately that you consider being the root cause of it.”
“I am really sorry to hear about the issues you are facing, but from the server end there doesn’t seem to be any sort of malice being caused that I believe could lead to this issue at hand.”

Hi again @al2code,

Before having to contact them again can you advise if you are using the Ezoic ad network like @Harmon? This might be the common thread here.

Yes I do use them.

Ok thanks for the heads up! I think that is the issue. They probably changed something recently and added that extra code which is throwing off the builder (it’s foreign to WordPress). As I stated in the other thread, regretfully I can’t promise that we’ll be able to make this work since we can’t guarantee compatibility with 3rd party systems like that. There might be a way for us to alleviate it in Pro directly so I’ll see what we can do there.

I see, thank you.

Looks like @Harmon has reached out to them about it. Just a thought, but could possibly expedite things on their end if they heard from multiple customers. Meanwhile, I’ll keep looking into a possible solution on our end.

One more update (mentioned on the other thread as well). I’m hoping in the next few days I’ll have a way in Pro (in a point release) to disable the integrity check or otherwise workaround this problem.

ok, thank you! Looking forward to it since we cannot post new content.

Hi @al2code,

For the next update I’ve retooled how the live preview detects if the HTML is suitable for actual previewing. I’ve updated it to account for the use case introduced by how the Ezoic ad network adjusts the HTML output. Once that update is available give it a try.

Hi guys, i want to try to chime in here. i had woocommerce and Wordpress installed. running PHP 7.3 and had the same issue:

  1. Increase your memory to at least 256M (in wp-config.php):

Then, make sure you are using WordPress 5.7. i didn’t run a minimal install test but weirdly enough I could test already created pages, create new POSTS but not pages because I get the same error you were getting.

After the update to WP 5.7 alongside with updated of all the site’s plugin, everything got fixed.

If WP 5.7 is installed already, try to reinstall it and see if that helps @al2code

I can confirm the new update that you guys released today solved the problem. Thank you, until next time.

Ok thanks for confirming! Glad to hear that fixed it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.