The preview could not load. WMPL - PRO

Hello there, I am using pro (latest version) hosted with Kista. The website is a multi language ones translate with WPML

When I load the editor on the defautl english version it works but when I move to the href lang version it shows me immediately the error " The preview could not load. This is most often related to a plugin conflict or aggressive page cacheing. Checking the developer console for errors could indicate what went wrong."

The issue is basically on this URL:

From my undestanding wplm should be compatible with Pro right? Can you please assist?

Hello There,

Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode:
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Switch to the parent theme to check if the issue persists.
  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  8. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Thank you, I tried all the points - everything is up to date, I have switched to the parent team. The php is a php 7 and it’s a 256mb now. I am using Kinsta cnd but I purge the cache and then disabled it but nothing.

The issue is caused by wmpl for sure because the error appears only in the ref lang of the url.

I’ll give you more information in the secure note

Hi @Andrea8Fortune,

Please go to WPML > Languages > Language URL format and change it into Different languages in directories. And make sure Use directory for default language is unchecked.

Then go to Admin > Settings > Permalinks and re-save it to flush it.

The lastly, go to WPML > Settings > How to translate posts and pages and select Create translations manually.

Then test it again, if you still not translated it then a popup may appear asking if you like to start from blank or from existing page content (English page as a sample). You can select any, but I recommend starting it from existing content as you can just change the existing texts as translation.


Thank you very much Rad, the process worked for the pages however now I have another issue with the header. I selected the translation of the header in WMPL but it does change only a part, not the menu. I am sure I am missing something. An example of an almost complete translation is on the page I put in the secure note, as you can see the header is only partially translated, the flag on top are not showing and you can’t go back to the english version.

Thanks in advance for your help.

Hi @Andrea8Fortune,

May I know which header is assigned to the one not working? It seems to be different, because when I edit the header of /pepperstone-review/ and switch to IT, it loads and works okay.

As for menu translation, please check this


Please see the secure note

Hi @Andrea8Fortune,

With that, I’m not sure which header is assigned to those pages at all. Please note that header could be assigned and you maybe editing the wrong header once you switch to another page’s language. That’s why I need to clarify which header is assigned to that faulty one since it works on my end when I switch the language through the builder.

Example, open the page /pepperstone-review/ then click Edit header as the above screenshot. Once you’re within the builder, click the IT flag and it works and load okay, and it displays the correct menu similar to English one instead of longer menu in /it/pepperstone/


I see what you mean now, but still I cannot give you the information you need because I did not work on any other header.

Pepperstone Header is assigne to the Pepperstone review page /pepperstone-review/ (eng) and /it/pepperstone/

I re-did the process I followed for Pepperstone with ICMarkets and the result is the same.

  1. I selected the Italian language in the Header section,
    2)I found the IC Markets one and clicked on Translate,
    3)I had the blank page and I selected copy content from the English Version
  2. made the changes and saved
  3. went back to the Header section and found the header correctly assigned to the ic markets page. Once I checked the live website in the IT version (it/ic-markets/) exactly the same.

am I doing something wrong? I’d like to have the header of /pepperstone-review/ assigned to /it/pepperstone/ page as well in its italian version.

From the editor I can do what you did, but from the page /it/pepperstone/ or /it/icmarkets when I try to edit the header it show constantly the caching error,

Also I double checked all the headers I created and they are ok and assigned on a single page, Pepperstone and ICMarkets are the only one marked as assigned to multiple pages…

Hi @Andrea8Fortune,

Thanks for the clarification, now I can confirm the issue and it seems to be related to redirect. And could be related to NGINX URL rewrite too.

And have you customized the theme’s core, I checked and the Pro version is not being added to <body> class at all.

Is there a way you can clone your site as staging on a different host? I’m not saying you have to move, I just like to test it on the different environment where there is no NGINX and internal cache. This one is weird, I tried your setup on my installation and it works just okay.

And for the meantime, please try re-installing your theme.


hey Rad,

I created a staging environment with no caching and no cdn but still NGINX server. Can you please test everything you can test here and then if you see that the only remaining variable to test is the NGINX server I will find another staging server.?

Thank you in advance

Hi There @Andrea8Fortune

I have tried to login to your WordPress backend, but I’m getting a white screen (see secure note).

Could you please enable WP_DEBUG mode by following this guide ( and re-test login into your back-end, so that you will see PHP error details related to this issue.

Let us know how it goes.

can you try again? it was an issue with the php 7.2, now php 7.0 is runnig and I tested personally. Thanks

Hey @Andrea8Fortune,

I checked your site and the header and content translation works. I changed the menu assignment in your Italian header to show you that it works. See secure note. I’ve also tested creating a new header and new page and experienced no issue.

It looks like something in your live site is causing the issue. Please try completely removing all optimization for a moment while the issue persists.


hello Christian, I really appreciate your efforts and the full explanation, however you missed the point unfortunately. Your video shows the error as well and the header you created has exactly the same issue i had.

Please check in the screenshot and in your video the different menus.

The English version has the “Main menu” version and the flag in the bar one - navigation inline. The French version has the standard menu.

This happens when you create an header from scratch and when you copy the content from the English page.

It is clearly some sort of glitch.

Sorry if I didn’t get the problem at first. I switched to the “Main menu” now and I got the issue. That happens because the menu does not exist so the navigation element chooses from the available menu automatically.

The menu does not exist because you don’t have a translated menu. I tested translating your “Main menu” for the French page and it shows up. See secure note.

Hope that helps.

Thank you so much Christian! That fixed the issue.

You’re welcome. Glad we could help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.