The preview could not load due to iframe response

If you do that, does Ezoic ads still show?


Thanks for sharing the log info. We’ll clean those up. It’s just some leftover unused variables. That wouldn’t cause any of the issues you’re seeing here.

Nice job on that DNS workaround! Glad you at least have something for the time being.

I believe it’s like they are bypassing Ezoic entirely, but only for specific computer they are using to work on the site.

Pro offers a way to edit pages live in real time. Caching systems often break this functionality and make the live preview non responsive. To avoid this we do an integrity check to make sure the page hasn’t been tampered with outside of the normal WordPress lifecycle. Those empty tags are probably just a false positive - no caching is taking place, but it’s still tripping how Pro tries to detect the presence of external caching.

In Pro 4.3.1 I ended up retooling how the detection on our end works. It account specifically for the use case here where Ezoic makes unexpected adjustments outside of WordPress. It still does some other integrity checks but is more lax about the final tags of the page being reordered. It will be going live in the next few hours on automatic updates so when you see it give it a try.

Using the local hosts entry means bypassing Ezoic entirely, so no ads, but it is only for the computer I am using. It is a workable solution for getting a few updates done but not a long term solution as you can’t use tools like the ad placement plugin this way.

Excellent. Looking forward to it. So you know, Ezoic gave me this:

I don’t believe this is specific to sitespeed accelerator, I think this is being caused by general Ezoic optimizations.

I’ve suggested to another publisher experiencing the same issue that should be able to use a subdomain to pull through a completely untouched version of your site for your integrity check.

This would mean they need to alter how the integrity check works to utilize a subdomain to pull the same resources through. You could suggest this to them yourself and see whether they’d be willing to do that.

Setting up a subdomain to make a page editor work feels like a lot to me. Hopefully the changes to the integrity check will solve the problem.

Hi @Harmon,

I think they’re right about it not being the accelerator considering you mentioned having that disabled. I don’t think a subdomain would actually work though. Pro needs the URL you are editing to be the actual URL otherwise it will show a cross origin error and not be able to render elements. Keep an eye out for the point release and fingers crossed that will get things working again.

Success! With 4.3.1 I can edit pages with Pro. Whew. Thanks for the work on that!

I am going to share some information no how to work through this. Is this also fixed in a version of X?

Hi @Harmon,

That’s great to hear! Thank you for confirming with us. The same changes were made in Cornerstone so as long as X users are on the latest version this will be resolved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.