The Grid no longer works in Cornerstone

Hi all,
Love the new features. That said, I’ve normally found a way to get the Grid provided with Pro to work whether it was in a content box, classic or new text or the legacy Grid element. But it no longer renders properly no matter what I try. Help please? See

This should be masonry and 4 posts side by side with controls below.

Hello There,

Thanks for writing in! I have inspected the page and and I only found two sections. One with two rows and each of the rows is just one column. Is this the correct page where your grid displays? By the way, please make sure that every thing is up to date as well.

Please let us know how it goes.

I’m always up to date. I had to remove it because it was embarrassing. No errors in console upon inspection.


Sorry to hear you are having this issue.

Can you create a test page and add the grid element, then send us the url of that page so we can check.

For the mean time you can try the following

  1. Test for plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  2. Increase memory limit.

  3. Make sure you have cleared plugin cache and browser cache.

  1. Make sure you have this verion number

The Grid: | Latest Supported Version: 2.6.60


All this is done. Oddly 2.6.6 just arrived today for me. But that didn’t fix it. It works great without cornerstone and it works great in The Grid’s preview. But when it gets to Cornerstone, it dies. Please fix and build an element v2.0 for it.

Hey Eric,

Since Pro 2.0.0, 3rd party bundled plugins preview is no longer supported due to reasons you can read in our past this news.

If your problem is in the front-end, would you mind setting up a test page with the grid for us so we could check the issue? Also provide us with WordPress admin access in a Secure Note so we could check your setup.

For the meantime, please try going to The Grid > Global Settings and disable the loading of the library globally.


That feature is off and was never on. I don’t care about preview. It’s working now with the Classic Text and shortcode. 2.6 must have done it.

Hi @ericgreenspan,

There should be no difference with the classic text + shortcode and grid element. It works the same as the element only wraps the same shortcode when displayed on the live page. But glad it’s working now, and if you wish us to investigate it further then let us know then provide your admin login credentials in the secure note for further testing.


What should be and what are may differ here Rad. I have been dealing with this for a long time. You just never know what will work with this plugin. I love it but it has many issues with displaying properly. I’ve tried in a vanilla config with cornerstone and same problems. Never an issue in ordinary wordpress.

Hi @ericgreenspan,

I see, but on my end, I don’t see any problem. It renders okay on any page I added it.

With this, we may need to investigate it and specific to your site. Would you mind providing your admin login credentials in a secure note? And please provide a video recording so we could reproduce it easier especially it’s not currently available in your page.


Not sure what to tell you. It’s working. It may be a plugin conflict but I cannot live without my assortment of plugins so I will just let it be.

Hi @ericgreenspan

I’m glad to hear it’s working now, if you want to test for a plugin conflict and don’t want to disable all plugins one by one on your live site, you might want to use “Health Check” plugin and enable “Troubleshooting mode”. The good thing about “Heath Check” plugin is that it’s developed by WordPress team and it only affects your logged in session so that other visitors won’t be affected.


It’s actually not working as it should. It’s better.

Nice to hear that, have a great day!

Now it won’t work again.

I’ve tried Content Area, Text, Classic text with shortcode. I’ve tried Classic Grid element. Nothing works. I’ve always had issues with it but always been able to get it to work. Help.

Reset global options, added library globally and now its working.

Glad you’ve sorted it out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.