The grid lightbox


I have some questions about the grid/lightbox:

*The grid:
** Get an image for thumbnail displaying (but it must not appear on lightbox). I think that with the main image of portfolio but no :frowning:

  • lightbox:
    **can i choose other transition between each image?
    **desactivate the lightbox between each projetc (thumbnail)?


Hi There,

Lightbox options for the grid is limited. It is basically turning it ON and OFF and this function is not available. You might want to check Essential Grid instead. Are you still referring to lightbox on the grid? If yes, there’s no option for image transition. Please clarify what you mean by deactivate the lightbox between project. Lightbox on the grid will depend on the skin you were using. You may opt to use a different skin if you don’t want lightbox for certain project.

Hope this helps.

Thanks for your response.
I have 3 thumbnails (for 3 projects):

  • First with 1 image
  • Second with 3 images
  • Third with 2 images
    So in lightbox, on the fisrt image I have 1/6 and I can slide over the 6 images in all.
    Except that my custom don’t want this system. He wants to close lightbox between each project.


Hi There,

Please share your site URL so we can check your setup. For the mean time, please check this guide for the default lightbox available on the theme:

Hello, i am using the light-box grid on one of my pages in the website. But how many lightboxes on one site I can use?
I wanna use 3 lightboxes on one page, but only 2 of them are working proper. The third is slow or hanging. If i cancel one of these three lightboxes the other 2 are running good.
What is the problem, or is one lightbox on one page the basic? Thanks for help.

Hi @panteufel

You could try improving your memory limit.

Would mind adding this in your wp-config.php located at the root directory of your site.

define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

You can add it before the line

/* That’s all, stop editing! Happy blogging. */

Here you have a video tutorial in any case:

Let us know how it goes, if that does not help, since we haven’t confirmed the issue of the other user is fixed, please open a new thread explain your situation and provide your URL so we can take a closer look.


Hi there,
I added
define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
define( ‘WP_MAX_MEMORY_LIMIT’, ‘512M’ );

like you wrote, but the same problem is there.
I tested different browser and i could see, that it takes a while the browsers loaded the
images, after a while trying the page works good.
Maybe the images are too big, but I don´t think so.
Please have a look, I leave the url.

Hello There,

I have checked the page in questioned. It seems that you are using W3 Total Cache. Could you please clear your plugin cache before testing your site. This can cause the changes to not take place on the front end. It will eventually show up when the cache regenerates, but it’s not ideal if you’re looking to see your changes immediately. Caching plugins are best to turn on only when you’ve finished building the site.

Please let us know how it goes.

HI there,
ok…i cleared up the plugin cache in w3 total cache, same problem.
Then i changed to w3 super cache, same problem
Then I changed back to w3 total cache, same problem
Then i minimized my images on this page, i made them very small, test with 3 lightboxes on one page…same problem

So i disabled one of the lightbox grid, only 2 of them are running and they are running good.
Fazit: It must be a problem of the number of lightboxes grid i use on one page.

Wha do think, is this possibble…?

Thanks for reply…manfred

Hi There,

I can see the issue that the third lightbox freeze. Please try to remove deeplink="true" from the lightbox shortcode. Try again after and let us know how this goes.

Hi Lely,
thanks for this, now it works…but the container size has changed and i don`t know how to make it back.
Hope you know what happend. The container after clicking the thumbnail …
thanks , manfred

Hi there, is ok, I found the problem…

thanks for everything…you are a great team…see you , manfred

Thanks for letting us know!