Text disappeared from site after update

Hi there,

X seems to have gone a little crazy on one of my pages. Not quite sure what’s going on but all the content is there. I can see all the elements in the inspector - the outline version - and I can even edit them. But the WYSIWYG editor shows no elements at all, and the page when loaded into a browser shows nothing except a header and section background colours.

Note that this is not site-wide though - its only the front page.

This has happened after I’ve done an update of Wordpress and plugins. So not sure what step killed it.

I have tried:

  • running Transient cleaner (which I understand is no longer necessary)
  • clearing browser cache
  • disabling other plugins

Any ideas?

Thank you

Hi @skyhawkmedia,

Thanks for writing in!

As you mentioned that the issue is only happening on your Home page and not on another page. There might be something related to the page content.
We can’t confirm the exact reason as we haven’t access to the site admin.
Only can suggest you troubleshooting to check if that helps. As you have already tested the plugin conflict I won’t add it again here.

  1. Ensure everything is up to date according to our version compatibility list at https://theme.co/apex/forum/t/troubleshooting-version-compatibility/195. Please follow the best practices when updating your theme and plugins. See https://theme.co/apex/forum/t/setup-updating-your-themes-and-plugins/62 for more details.
  2. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Remove custom CSS, Javascript and templates.
  5. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  6. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php
    define( 'WP_MEMORY_LIMIT', '256M' ); define( 'WP_MAX_MEMORY_LIMIT', '512M' );

In case the issue persists, would you mind providing us with login credentials so we can take a closer look? Please provide following information:
Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials

All the best!

Thanks for the quick reply. In response…

  1. all up-to-date
  2. done
  3. not using CDN
  4. customisation is done with child theme and header injection. Tried changing child theme to regular X theme and tried disabling header injection plug in
  5. done
  6. Haven’t done this yet. To be honest it is not a memory-hungry page and is really smaller than other pages on the site that work (so I really don’t think it is this)

Secure note added.


Hi @skyhawkmedia,

Could you try upgrading your PHP version to 7.2? Your current PHP version is quite old while your Wordpress is 5.0.3. Then we’ll continue checking.

You can contact your hosting provider for PHP upgrade.


Now 7.2

Hi Steve,

Upon testing your issue further, it seems that you’re experiencing a plugin conflict. I have disabled all of your plugins by using a plugin called health check (https://wordpress.org/plugins/health-check/) which allows to test your site without affecting your live site users by switching to special troubleshooting mode. Once I have tested your site only with Cornerstone plugin, your content started to appear (see secure note).

To see which plugin causing the issue, I would suggest you to activate your plugins one by one. You can also check the following tutorial if needed (https://www.youtube.com/watch?v=nO1nP1gBstM).

Hope that helps.


Thanks for your continued help.
I have deactivated all plugins except cornerstone. However I do not see any improvement. Other pages still continue to work but I get nothing from the front page (except a green bar which is the background colour of one of the sections).

Also I cannot see your screenshot. I attach my own screenshot though.


Hi @skyhawkmedia,

Upon further checking, it appears to be caused by custom CSS.

.x-logobar, .home .masthead, .home .x-colophon, .home .x-container, .home .x-topbar {
    display: none !important;

Please remove it and it will start displaying.


Hi again,

Sorry, but this is not the right answer.
It certainly makes the logo header appear…but the header is hidden for a reason - I don’t want it.

What I’ve now done is this: I’ve restored the pages back to where they were and the site is working again. But I’m certainly confused as to how.

Originally I had an “Enter Site” landing page that I was trying to get rid of. It’s just a logo with an “Enter site” button. Old fashioned and I want to lose it.

So I have this
Page A -> (enter site) -> Page B
and I want this
Page B

So I just set the new landing page to be the target of that button (using Settings -> Reading). That’s when the content of Page B disappears.

So I’ve just set it back to the way it was, and it’s working again. Huh?

So if you go to the site now, you will see a large logo with an Enter Site button. Hit the button and you go to the “main” page. All I want to do is make that “main” page the home page.

The Enter Site page is actually a page occupied by a revolution slider (the enter site button is part of the slider).

Thanks for your continued help

Hello @skyhawkmedia,

You do not need the css code to hide the header and the footer. Please remove this css:

 .x-logobar, .home .masthead, .home .x-colophon, .home .x-container, .home .x-topbar {
    display: none !important;

What you will need to do is to edit your landing page and change the page template to Blank - No Container | No Header, No Footer.

I already went ahead and fixed the issue.

  • I changed the page template
  • commented out the css
  • added another css block
  • added the rev slider shortcode into the page content

For more details about the page templates, please check this out: https://theme.co/apex/forum/t/features-page-templates/50/1

What CSS did you add?

ok, your fix above showed content…just not the right content.
But your fixes gave me enough clues to resolve the issue.

I’ve left the page as No Container. Header,Footer. Changing it to No Header removes the mast-head, the slider and the menu. So I amended my original CSS to ONLY set the x-logobar to display:none.

The page now loads and looks correct.


Glad to hear that. Have a great day! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.