Templates improperly formatted, do not upload properly

I maintain 2 identical sites- both have same version of X, PHP, WP, plugins, etc…
None of my pages I created templates from have errant HTML or Classic theme elements.

Downloaded the templates to use in the second site and about 65% upload it just stops and shows error “improperly formatted”. Did it on a page that had current elements and no css, errant html or anyting special. => ERROR
Cleared all Cache, switched to another browser , tried a different network => ERROR
Did not have this issue in version 6.x of X theme- now in the 7x ver. it’s just annoying.

I purchased X themes so I would not have to recreate pages - and save some time- but this is just ridiculous.

Please advise.

Hi @markomark,

We’re sorry to hear that you are having troubles installing the theme but based on the error message you are getting while installing the theme, you might be trying to install and incorrect file.

If you download the theme from ThemeForest, please make sure that you download the file from Installable WordPress file only and not from the All files & documentation.

If you download from the All files & documentationlink, you will have to unzip the file first and find the x.zip file and use that file to install.

You may also download a copy of X from your dashboard:

If you have the correct installable file but you are still not able to complete the installation, login through FTP then go to wp-content/themes then upload the unzipped x directory there and go back to the admin area and enable the theme.

In case the issue persists, please provide us with the admin access to your site in a Secure Note:

Please re-read the original post -there are EXISTING SITES> Issue is with template manager in X

Hello @markomark,

I can see that you are using the latest version of the theme. Most of the resources of hakubaku-usa were actually hosted in myftpupload. There could be a CORS or Cross Origin Resource Sharing issues. To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288

Best Regards.

Hey @markomark,

What you encountered is a but in Pro 3.1.2, X 7.1.2, Cornerstone 4.1.2. What’s happening is, you can export 1 template at a time only. Exporting multiple templates result to broken export file.

I don’t see this happening in Pro 3.2.0, X 7.2.0, Cornerstone 4.2.0. Please update to the said versions.

Hope that helps.


  1. Updated both sites to latest versions of X and Cornerstone. Same error when downloading single file and uploading template to other site.

  2. Also does not work when downloading from target site and trying to upload to original site.

  3. Downloaded template, renamed it, uploaded it the the same site- and still won’t load - error.

Please advise.

Hi Mark,

Try deactivating ConvertPlus plugin first, and then import template. I saw same case of this and ConvertPlus was the culprit.

If that still not work, please do testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes,

Yes. Convert Plus does not play nice. Turned it off and works now.

1 Like

Glad sorted things out on your end now, and thank you for confirmation.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.