Templates Broken

I have seen on here a number of posts about templates not working. I am now getting this on a number of sites. We have created a number of templates so we can quickly build sites. The only templates that now seem to be importable are the ones that come built-in.

I built a new server instance for testing. I created pages with non-classic elements, classic elements only, and one that was a mixture of classic and new elements. I saved each page as a template. I was able to make new pages and use those templates. I was able to export them just fine.

I tried to import them to a new wordpress install with no addons except cornerstone and it failed. I then tried to import it back into the wordpress instance it was downloaded from. That also failed.

Clearly there is an issue; can we please get this fixed?

Hi @mobeus,

Thank you for writing in and sorry that you’re having that issue, can you confirm that the donor site and recipient site has the same PHP version? Please provide us login credentials where can we get the template in a secure note so we can take a closer look.


@friech yup they are same version of everything. This was working pre v7.x. I have made the secure note.

Hi @mobeus,

There seems to be a problem with the original website that you want to have the templates from. There is a security feature turned on that I can not access the pages at all and it keeps loading the User profile page. There seems to be a security plugin that is in the way.

Would you please test the template import by disabling all the plugins? Also, I’d appreciate it that you change the Theme from Child theme to the parent theme and then test the template import.

I performed another test, I created a template from the destination site as I do not have access to the source site. I just added a page called Themeco Test and imported successfully on my local installation:

Please kindly add a new page and do the test for the source site too, so we can see if it is something related to your previously added pages only if it is happening to the new pages too.

Thank you.

It was trying to force 2 Factor Authentication on the account that was made for you. I have turned it off so you should be able to get to anything to test.

I can use all of the templates on the source site for any page new or old. The issue comes from exporting a template from the source site then importing it into any other site.

Hello @mobeus,

Please check your server settings first. You can check out the site health in the link added in the secure note.

I have tested several templates both from the Design Cloud and my own and it goes through. Can you please provide us the URL of the page where we can test to save as a template and import it to another site or even in our local testing server?

Thank you in advance.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.