Suppressing Navbar on Individual Posts

Hi, I have mimicked single page navigation with the navbar in the Ethos stack. The problem is that when an individual post is selected (using the posts the navbar appears on the individual post page and of course does not work because it is using the #ID functionality. I will put a “back” link or something in each post that’s fine. I just can’t figure out how to suppress the navbar in an individual post.

Thanks for the help.

website is

UPDATED: Also, if possible with the “Latest Posts” Element to open up in a separate window on the click event.


You need to create two menus, for one page and for your primary menu.

The one page menu will have hrefs as ids


Contact Tim - #ContactTim
Find Tim - #FindTim

This is the menu that you will set as your one page

Then create another menu and set the links as abolute links.


Contact Tim -
Find Tim -

Set this as your Primary Menu

For more information, kindy refer to the link below.

Hope that helps.

Hi Paul, thanks for the help, I don’t see those options on my implementation of wordrpess. Here is a screenshot of may WP Manager:

Hi There,

I am little confuse which options you are looking for.
The two menu should be created on Appearance > Menu
When you edit Homepage, below page settings, that is where you can find the option for One Page navigation. Can you clarify what have you done already and which part you can’t figure out?

Hope this helps.

Thanks you Lely, I found it, it wasn’t clear to me from the last post where this setting was. I was looking for it in the root level of “Pages” rather than actually editing the Homepage individual Page settings. Problem solved thank you!

You’re welcome!
We’re glad we were able to help you out.