Suddeen lightbox bug - same code used, but sometime sworks sometimes doesn;t


I have loads of lightboxes throughout the site, they are all setup the same way and they have always worked…suddenly a lot of them wont; show in lightboxes but instead open up a new page (and we have to use the back button)…

No code was changed, I don’t even think that I had upgraded WPress when this happened… ?

AFTER it happened I upgraded WP, X theme, Cornestone and WP Lightbox … the issue remains.

In Secure Note I have pasted the 2 x code and you ca see they are the same setup, but one wkrign and one not…

ALSO - and this may be related … ever since I updated X theme and Cornerstone, the Cornerstone editor is REALLY buggy, takes ages to loads, and on some pages it won’t load at all I get the error msg that lots of others have complained about: “The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing”

I didn’t have ANY of these issues before…?? It seems that your latest version of conestone and or X theme is extremely buggy.

Please help urgently, thanks… Will post login details.

Hey @kirk74,

I inserted the shortcodes you posted in a test page I created in your site (see Secure Note) and both worked fine.

I experienced the issue with Cornerstone though. Please follow the solutions in our builder troubleshooting guide.


Thanks … so with the test page you created, you can see that my lightbox code is correct, as it works on the page you created… but in the actual site it sometimes works and most times doesn’t … so I think it MUST be related to the cornestone builder issue…??

I looked at the troubleshooting document you directed me to, but this did not help … can you take a closer look please.

I the troubleshooting document it talks about the protocol and path needing to be the same in the Original and Preview paths … in my case it always seems to make the Original URL the homepage - this is different to what is described in your troubleshooting document … does this offer any clues??

The error message suggests that the issue might be due to caching. I see you’ve used WP Super Cache. I see it’s deactivated. I activated it and cleared the cache but it didn’t solve the issue. Sometimes, clearing the cache doesn’t solve the problem. Please give us cPanel access and we’ll try to completely uninstall WP Super Cache to see if it will fix the issue. We’ll also try resetting your htaccess.


thank you so much for helping. I added the FTP login to the secure note.

Hey @kirk74,

I have tried resetting your htaccess, increasing your memory and deleted WP Super Cache but the loading is still very slow.

I see you have other WordPress installations within your main WordPress install. If you’re in a shared hosting, this will affect your site’s performance moreover you’re using a page builder.

Is it possible for you to move your site to a separate server? If you can, here’s our migration guide.

Can you also deactivate all third party plugins while we are troubleshooting?


Hi. We had none of these issues until just recently… this is a commercial site that is accessed constantly and it is super-imperative that it works and is as fast as possible.

I am thinking that I should revert to a backup and hopefully then it should work as before… and then can avoid updating until some of these bugs have been ironed out (because it is extremely alarming just how many people are seeming to have issues with the latest version of X theme?)

I use UpdraftPlus so I cold revert back to a couple days ago. Do you think this would work?

Then I can try updating on a testing server instead and make sure no bugs before we do it on real site.

(I am still concerned about why lightbox suddenly only working inconsistently, as this seemed to be happening before I updated, this was the reason I updated… but dealing with just this will be easier than the issues I now have since updating… your thoughts please?).

Hey @kirk74,

Yes, please revert to your backup because its a live site and it is important for it to be operational.

We could then continue troubleshooting in your staging site.


Hi again,

OK I have been troubleshooting for hours … and with JS Console open I am getting some clues…

On all ages, I am getting this JS error f;ag in the console: Uncaught SyntaxError: Unexpected token <

And if I click that to look at the rendered HTML, it shows the HTML starting on line 7 … there should be this gap there, it seems something on the X theme or Cornserstone plugin that must be causing that?

And - after some googling I found that Contact Form 7 has been known to cause an issue lie this … SO I tried disabling it, and if I disable it I DON’T get this JS Console error … BUT we Do need ti contact form…

Your thoughts please?

Hey @kirk74,

Contact Form 7 does not have any issues in my test site. Would you mind providing the URL of the page of your staging site having this error? Please also give us access to your staging site’s WP Admin.


Can you please look above, as i provided all this earlier their is a secure note

To help with the troubleshooting, I have tried making a new page and editing that in Cornerstone, and it all works fine … so the issue with the Cornerstone builder not loading seems to be only with existing pages… and also pls note that i CAN see the sections on the left, I just can’t see the actual preview part where you select elements to edit. … see screenshot

( Note - I have had my web host increase the max_execution in php.ini from from 30 to 300 )

OK I have (some) progress … I am now able to access the Cornerstone editor sometimes … so this is better than before… It is still super buggy, often won;t load (same error message as above) … and even when it does load it seems to take wayyyy longer than it should so I still need help nutting this out…

I have JS Console open, I will put the error messages in Secure Note

Hi there,

You can ignore the source-map error, the debugger is looking for that file which doesn’t exist. It can be turn off but not in Safari browser.

About the loading, it sounds like performance issue and could happen when the server resources are too limited due to traffic or processing. Are you on shared hosting? Because this usually happens in shared hosting.

That popup warning will appear even if there is no error IF the server response is taking long (about 20 to 30 seconds and above per requests). And in the builder, it could take hundreds of requests per load which is yes, too limited on shared hosting environment. You could try another host just for testing and as staging.


Hi … thanks for you response… but none of this was an issue before?? and the lightboxes are still not playing on lots of the pages and they always did before… I really need someone to pls take a closer look than the generic “try a different server” response …

Thank you.

Hi there,

Sure, we’ll continue checking. I only stated that it could be performance related based on the information you gave. A different staging or server is just part of troubleshooting to narrow down the issue as we need to confirm all possible causes.


Thank you…

I am reading different things about PHP lately … one of your support team, at the end of this thread recommended we be on minimum 5.6.3… in our case we are on 5.5.33 … but then in multiple other threads I have seen you guys recommended PHP 7.1

So as a next step shall I ask our host to upgrade to 7.1 and see how that goes?

UPDATE MARCH 6TH - Just for anyone following this … The new setup did not like the previous way I had done my image lightboxes, so any ages that had this it then forced the video lightboxes further down the page to play in tabs rather than lightboxes … I did it a different way and visually it was the same result but it didn’t stuff up my other lightboxes on the page … this thread explains how I did it the new way:

Hey There,

Please keep in mind that WordPress 4.7 requires at least 7.0 ( In most cases you cannot update your PHP version yourself and need to contact your host about this. The upgrade process is an easy process and should be something your host can do for you without affecting your website or charging you for it. Here’s a letter you can send to your hosting company:

Dear host,

I'm interested in running the open-source WordPress <> web software and 
I was wondering if my account supported the following:

- PHP 7 or greater
- MySQL 5.6 or greater
- The mod_rewrite Apache module
- HTTPS support

Looking forward to your reply.

Hope this helps. Kindly let us know.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.