Styling missing on just the Home page after upgrading to PHP 7.2

I tested updating PHP 5.6 to PHP 5.7 on a STAGING site that is using a child theme (site originally started as Ethos)

The site did not experience any major issues when I upgraded the PHP, other than some paths to some images being corrupted. But the styling and the content was still in place, which is good.

Later I updated PHP 5.6 to PHP 5.7 on the LIVE site. (I did not “push” the staging site to live because it had the issues with image links.)

After updating the live site I saw that the Home page was a mess! No styling other than some colors. BUT - all the other pages are fine. They have the correct styling. All image links are working, too.

I have been working with the hosting company; I notified them that when I viewed the source code of the LIVE site and compared it to the STAGING site (STAGING site’s Home page is formatted correctly) — that I found that on the STAGING Home page source code there are links to two files that I do not see on the LIVE Home page.

These lines appear to be missing from the LIVE Home page (note: these examples do not include the actual website url): (the staging one used this link and it worked on staging)

The LIVE Home page uses this link: - not sure if it works or not. Just trying to find differences.

This line is in the source code of the

In addition I see that there is a javascript reference on the LIVE Home page which is NOT on the STAGING Home page:

script type=‘text/javascript’ src=‘

Since this line does not lead anywhere (it does not exist!) it is not operational. But I did not see it in the source code for the STAGING Home page which shows styling.

I don’t know if these differences are causing the issue on the LIVE Home page, but I was trying to see what might be different.

The hosting company advised me to remove and re-install the theme — so I did that with the X theme. (The ethos theme doesn’t have any updates, does it?) The theme that is actually “active” is the child theme which has not been modified in years.

I don’t see a way to post private content here, so I have changed the name of the site in the urls to protect my client’s information. The instructions said there would be a “Secure Note” section, but I guess I will only see that when you reply.

I appreciate any help guidance you can give me; the hosting company does not seem to understand what is going on.

Thank you.

Hi @SnowWolf,

Please double check if you have both X and Cornerstone updated to the latest version as it will mostly cause an incompatibility issue if they are not in the latest version.

If both are updated, please provide us with the admin access to your site in a Secure Note:

Thank you.

Hi Jade, I just posted a secure note with the full urls and then another secure note with login info – but I only see the secure note with login info. Did the other secure note post – the one with the urls?

Hey @SnowWolf,

You’re using W3 Total Cache, please clear all caches and also clear your browser’s cache then check if the issue persist. Also check in incognito mode and other browsers.

If clearing all caches does not help, the issue might have something to do with your setup of W3 Total Cache. In that case, we need it to be deactivated all also all the third party plugins to be deactivate before we continue to investigate.

The reason for that is we need to know if the problem is within our product and not caused by third party factors.


1 Like

You were correct! I disabled W3 Total Cache and the Home page style became active. Yay! I noticed page load became extremely slow after that, so I enabled W3 Total Cache and now the site loads quickly. Thank you SO much! :slight_smile:

I should have come here first for help… I’ve spent a couple of days communicating with the host company with no luck. They kept sending me to Wordpress instructions at I did let them know the resolution that you gave me, so that perhaps they will start out with that suggestion if someone else experiences a similar problem.

You’re welcome!
Thanks for letting us know that it has worked for you.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.