Space at top

how do i get rid of this space at the top of the parallax header?

Hello There,

Thanks for writing in! The space above your header image is coming from an auto generated p tags. This usually happens if you are using the default WP editor mixing text and shortcodes as your content. I would highly suggest that you use Cornerstone in building your page. At this time, you only have an empty p tag which contributed the spaces. Sooner or later as you add more content to the page, it will get complicated which could even messed up your page layout. Using Cornerstone in building the page prevents any of those mishap. And with Cornerstone, you should be able to control almost every section, rows, columns and elements you will be adding into the page. To know more about Cornerstone and how you can use it, please check this out: https://theme.co/apex/forum/t/cornerstone-content-builder-introduction/118/1

Hope this helps.

this is not a solution. i got x-theme to customize the code per someone’s recommendation.

cornerstone does not allow the customizations i want.

please provide a solution for overriding the auto-generated p tags.

Hello There,

When using the default editor with your text contents mixed up with your shortcodes, one thing you have to keep in mind that in every line break, new line or a double space line, WordPress editor will automatically convert it to a <br> or <p> tag as soon as you view the page live. There is no solution to that since we do not override default WordPress settings. Because of this issues we have introduced WP Visual Composer and Cornerstone to easily build pages without any hustle.

In your case, since you are using shortcode, you must always refrain from using new lines or our double space lines. Instead of having something like this:

[content_band bg_color="#ffba00" border="all"] [container] 

[column type="1/2"] Place your content in here. [/column] 
[column type="1/2" last="true"] Place your content in here. [/column] 

[/container] [/content_band]

In order to prevent any extra spaces, you must prevent the use of any new lines or line breaks just like this:

[content_band bg_color="#ffba00" border="all"] [container] [column type="1/2"] Place your content in here. [/column] [column type="1/2" last="true"] Place your content in here. [/column] [/container] [/content_band]

Hope this make sense.

this doesn’t make sense.

on a different page, the space is gone at the top. (see screenshot)

how do i achieve the same result on the home page (biotobody.com)

Hi there,

Are you using shortcode for the homepage? If so, kindly make sure that there are no white spaces before the first code you have added to avoid the blank <p> tags.

Another option would be to place this in the Global CSS:

p:empty {
    display: none;
}

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.