Snippet not coming for my posts on the homepage of my blog

I have a blog( Snippets are NOT coming on the homepage for my blog post. Could you please help me with the way forward?


Hello Abhijat,

Thanks for writing in! Are you referring to the post excerpts? Please make sure that you did not add any manual excerpts. If you wrap your post contents with a shortcode, it will not display the excerpts too. That is because excerpts were taken from the very first 55 words of your post contents. And there could also be a 3rd party plugin that is causing it. You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

And if everything else fails, would you mind provide us your WP login details in a secure note so that we can investigate your site? To know how to create a secure note, please check this out:


I’ve tried removing all the plugins, still I’m not able to get excerpts on my home page. Kindly let me know with options.

Hi Abhijat,

I can see you have Endurance Page cache installed. Can you clearing your plugin cache then check again.

If that doesn’t help, pelsae provide us your wordpress admin login in Secure Note

Hey Paul,

I’ve removed the endurance page cache, but still the excerpts aren’t coming on the first page. Let me know the way forward.

Hi There,

Please share your admin account and password under Secure Note.

Thank you.

Could you let me know the way forward?

I was interacting with Mr. Paul. Henceforth, you’ll carry the discussion forward?


Hi There,

Paul works on the different shift so he’s NOT online right now.

Please try with the following steps below:

  • Try adding the manual excerpt for your posts to see if the excerpt appears on the blog page.

  • Turn off the FULL POST CONTENT ON INDEX option under Theme Options > Blog > Content:

Let us know how it goes!

Hey Thai,

Already the full post content on index is off. I’m able to add a manual excerpt and it is displaying on the blog. However, it is NOT the solution, I need the perfect solution. Let me know, how much time will you take to find the solution, It’s over more than 10 days.


Hi Abhijat,

Please note that the thread took up to 10 days since you have responded 6 days after Paul responded. Also, it might be a different staff that will handle the thread depending on who is on shift when your ticket active.

We would love to check this further to see what is causing the automatic excerpt not to show up on the homepage. please Provide us with the admin access to your site in a Secure Note:

Hello Abhijat,

You have provided only the password. You seem to forgot to include the username.

Meanwhile, I have check your single blog post and I can see that you are using the WP editor in adding the contents. Most of the time, the excerpts would display. In your case it is not. I am guessing that you may have installed a plugin or added a custom code which alters the excerpt content. If only I can log in to your site so that I can figure out what is causing this. Please update your WP credentials in the secure note and make sure to give the username and password so that we can log in.

Best Regards.

Hi Abhijat,

I have logged in and investigated your issue.

I created a test page:

And my test page is showing in your blog index:

I have edited some of your posts:

It seems that the contents were in an html block or something in which the excerpts will strip out and why there is no excerpts. You might need to edit your post or somehow get rid of the blocks that is causing it.

Hope this explains it briefly.

Hey Guys,

How to change the fonts of body content as well as h2 and h3 tags. Expecting a fast response.

Hi there,

You can set the body and heading fonts in X > Theme Options > Typography.

Hope this helps.

Nope, it didn’t helped me, I’m asking how can I change the font pixels like 32px, 18 px etc.
Secondly, let me know the way I can change the font. Here, there is a limited option only.

Hi Abhijat,

Yes, the default Wordpress editor (Gutenberg) is limited in font-styling because it just inherits theme’s styling.

Please navigate to X > Theme Options > Typography to adjust your default Typography styling, you’ll see there the ROOT FONT SIZE those are the base font of your site on different screen size. You can not have a big 32px font on a small mobile, keep the responsive of your text/content in mind.

Also, under Theme Options > Typography you’ll see the CONTENT FONT SIZE (REM), 1rem is equal to the value of the Root Font Size per screen-size (refer back to ROOT FONT SIZE). For Headings, its percentage basis h1 is 400% of Root Font Size and h5 is 150%.

There (Theme Options > Typography) you’ll also see the BODY FONT and HEADINGS FONT, if you want to use a different font-family and color on your body content and headings you can do that in there.

But, if you really want to be specific with your font-size and other styling of your font, you can do so with inline-style


<p style="font-size: 32px;">Lorem Ipsum Dolor</p>

<h2 style="font-size: 32px;">Lorem Ipsum Dolor</h2>

But that is not responsive and not efficient. You don’t want to go back on all your content to edit that when you’re going to change your font styling, right?

Tutorials for Gutenberg WordPress editor


Hey Buddy,
I’m a beginner and I’m not well versed with the technicality.

I just want to set my fonts like this website (

Could you please help me with the steps ?


Hi @JustABHI,

It’s just as provided by @friech, I will provide a sample video recording.

You can change the font setting through elements setting if you’re creating the content through the builder. Then you have to manually code it if you’re on the standard editor as there is no way to change it is with Wordpress default editor.

But if you wish to globally change the head title’s font size to something you don’t wish to configure through those settings, then simply add this CSS to your Theme Options > CSS

h1, .h1 {
font-size: 40px !important;

But again, you still need to apply the font family in Typography setting applying them.

Are you just trying to copy the body and heading font family from If yes, then simply add body and heading font as how it was added on my video recording. Both body and heading font on that site is Open Sans,sans-serif;, with just different sizes and color.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.