Site and cornerstone issues

Hi There,

I changed the PHP version to 7.0 and the cornerstone is working fine now.

I also updated this code in your wp-config.php file:

define('AUTH_KEY',         'ba}hkcTf#ttR&|0wOt#XPKH+@%_FDvX}UIRgv]+ElXPX)?2?tP@Fl6qh%J5}p!mK');
define('SECURE_AUTH_KEY',  ',}e<P]~6jl~rItqL@a{T8c/$9%~Q|)qa57JSy9E=h|fGP%u);P7,TnS+I+gD$QWt');
define('LOGGED_IN_KEY',    'lJ6V5IQr_z436:l]!Esab-3,WV<]y|rde]R=-E+|gii)cZawVy69M|kQ~,WX5>>D');
define('NONCE_KEY',        'E6r CY+ {hCvpKXbA<+kF^JCYw$xdZ{j6-w_XERObWJ~zH_+@E8qsh2~?aar^BvV');
define('AUTH_SALT',        'drlcM> WVFoG%*E^T^+!620a$m6)]uuG5uxg>;$k-;gRTj(nDuUS/+*p%oOK|+ 3');
define('SECURE_AUTH_SALT', 'N909cm`xE(fCrr}/~kR+Yipmrqt6KgN!}7`{ei Es{5Cb|SQYPxMBE7*Q$W1/Vmy');
define('LOGGED_IN_SALT',   'E|*C}CgK3{2H,T,4ct{Nj4T&VnJI1/N]}L9E2alWD|*Y%e++j|YYX-Zezo?zoC-r');
define('NONCE_SALT',       '&#%!W3O9!Ce%RN&Sk0g&[_$9+*1RnJKnuI8QU4~h&AaQ>w`VPz=k&7~H0+2lt-c%');


Hi and thank you for that but I am still not seeing anything under the Header settings area in cornerstone.
I tried as well in different browsers and i’m still not seeig any options there:

Hi there,

I can confirm that and there is no error at all. Could you try cloning your site in staging (in a subfolder maybe). I’d like to try a complete re-install without that table fixing/repair issue (leave the tables as is).


i’m not entirely sure how to do that but I can give you cpanel access if that helps?
If you reeeeaallly have to, you can re-instal fresh. I’m not too far in and would prefer not to loose what I did, but I also am loosing time so just do what you must… More important I can continue working in the end.

Hello There,

I was able to create a staging site just to compare your settings.
You can check it in the secure note:

It seems that the Header options is working unlike what you have in the main site. Please advise if you would like to reset your main site to finally resolve this issue.

Kindly let us know.

Hi, yes please and thank you. If it must be done lets go ahead

Hello There,

I went ahead and reset your WP. Afterwards I have re installed the theme and the APP demo content. The header options is now working.

Please check your site now.

Hi I can’t get in though and the temp page is gone so the demo content is showing right now. I need to change that quickly. Can you give me the admin login details?

Oh phhheww I was able to change it and get access through PHPmyAdmin

Thank you for your help!

You’re welcome! We’re glad we were able to help you out.
If you need anything else we can help you with, don’t hesitate to open another thread.

So one last things. The demo content is a bit different. There is a slider at the top that says"blog" instead of the one shown in the demo for the homepage. I can’t see anywhere where I can get rid of this? Normally I would change it under the page settings for “below the masthead” but I only have the option to assign the homepage content or other:

I guess a newer update has changed some things as cornerstone looks much different.

I should mention that o the front end, I do see the correct slider, however in cornerstone when editting the homepage, it shows the blog header:

In eithercase, how would I remove the slider on pages?

Hello There,

Thanks for updating in! When I edit your homepage, this is what I see:

I am not sure how the Blog header came up or where it came from. Maybe from your browser cache. Please clear your browser cache or use private browser mode and test your site again.

By the way, to remove the slider on pages, just each each page and deactivate the sliders in the slider settings. For more details on how you can use slider in the theme, please check this out:

Please let us know how it goes.

I’m still finding cornerstone quite slow and sometimes unresponsive. Even if I close the editor, clear my cache and open again.
Often I change a setting and it take a long time to actually change. Sometimes the page loads and I cen see the sections etc on the left pannel but the site content loads like this:

Any ideas? I now you changed my php version to 7 and upped my resources.

I have other sites on this server that don’t have these issues.

I am only using bundled and approved plugins.

Hello There,

The issue could be intermittent. Whenever I edit a page I do not encounter any issues at all. Everything is smooth from my end.

Please clear your browser cache or use private browsing mode in testing your site.

Please let us know how it goes.

Did what you suggested with the same results. I didn’t have these issues with the past versions of Xtheme.

Hi there,
The previous versions of the theme had completely other underlying technology using the Backbone, but the new version is using the Ember technology, so it is not possible to compare them or try to say something was working before and not now.

The intermittent problems are usually due to the hosting service provider resources problem when you use the shared hostings. You need to make sure that you have at least 512MB of the PHP memory limit and your hosting service provider is fast enough.

Please test the case by moving your exact same WordPress installation to another server or your local machine.

Please consider that our development team always refactor the code to make the builder ask for fewer resources but this takes time and if the current resources of your hosting are not enough you have to consider changing the provider as the code change may take several months to improve stuff naturally.

I suggest that you check our hosting service as it has 100% resources needed to use our builders and is compatible with our ecosystem:

One other important point is that kindly open up a separate thread for additional questions as this thread is getting longer and longer and is not serving the original question and it is getting hard for us to maintain and give you proper support. Kindly always keep each question separated by its dedicated thread and we will be more than happy to help.

Thank you for your understanding.

The article here: says the minimum is 256M for the memory limit which I have set (you actually set this for me). I upped it to 512M however as you recommended.

I’ll try moving it to another server to test, but from what I see, I am meeting the criteria you mention for my hosting (i’m with Hostgator).

I understand that the previous version of X cannot be compared, but doesn’t Pro also use Ember? I have pro working fine on my other sites on my hostgator server.

I apologize for the long thread, but thought it best to continue the same conversation with the people who have been helping me, rather then open another thread on the same issue.

The issue is just intermittent, so I can work around it I guess, but it’s just really annoying and glitchy to have things not load at times or timeout.

BTW, I did look on the hosting page ( but it seams that none of the links work for the discussions on specific hosts. I was hoping to see what others had to say or if they had similar issues.

Thank you for your help

Hi there,

Thank you for your message. You are correct the 256MB is the recommended one, but as other plugins also need resources we may be on the safe side to have the 512MB version.

That is correct, Your server info indeed meets the prerequisites, the reason we asked for the test is to make sure there is no other possible problem such as a mod_security restriction or firewall or a factor that we might not have taken into consideration and the best way is to test in a local machine or the other test server.

You are right the Pro also uses the same Ember technology. So we can make sure that the difference between backbone and ember is not the problem on your case.

I totally understand regarding the long thread. Thank you for considering our suggestion regarding the threads.

Yes, I agree and I think we should keep investigating the case as having this intermittent fails will slow down your development process.

The link I provided is the landing page for our hosting service. I suggest that you check our peer to peer forum and ask for the opinion of our customers regarding the hosting service;

One last thing that came to my mind that might be the problem cause and I suggest that we get it out of the way is the PHP Script Execution time limit. The servers usually have it in 30 seconds. Kindly ask our hosting to make it 300 seconds to be on the safe side.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.