Settings for responsive columns missing

Hi my settings are missing for responsive columns in visual composer with x they was appearing before last update I only have design options no visibility for devices option?

attached image is what it used to look like

Hi There,

Thanks for writing in! This feature has been disabled while ago, because it’s not compatible with the X grid system.

You can use our visibility shortcode instead (

Or else we would highly recommend using Cornerstone when building your pages, so that you can easily create sections, rows, columns and even hide/show these sections in different screen size. For more details about Cornerstone, please check the following guide (

Let us know if you have any other questions.

I’ve spent to much building with vc page builder to start again plus the visibility shortcakes aren’t compatible with vc content can I use a plugin to enable this there is one that is compatible with vc I have been looking at? I’ve been building a site with a full page scroll like this wondering if cornerstone is capable of this?

Hi There,

There is a Hide on device option if you want to hide a column. If it does not appear on your end, navigate to WPBakery Page Builder > X Integration and do not check the X Integration box.

Unfortunately, X/Cornerstone does not have that library (fullPage.js) integrated.


thanks friech just wondering why hide on device section isn’t showing up like backend editor above I’m getting responsive settings now ?

Hello There,

When you enable X Integration in WPBakery Page Builder > X Integration some of the VC elements and functionalities will be removed. If you have been a user of VC, I would suggest that you disable X Integration so that you will have a vanilla version of VC. To know more how we use this plugin in X, please check this out:

Hope this helps.

hi i disabled integration ?

Hello There,

Please disabled X integration and you will have the vanilla version of the Visual Composer.

Please let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.