Service Mark on Android

About halfway down our homepage ( I am using the html for service mark (℠).

It appears fine on web browsers and on my iphone, but the service mark won’t render on chrome on an android phone, a tall vertical box appears in its place.

Any suggestions on how to fix this?

Hi Megan,

Thanks for reaching out.

Yes, I can see that that. Could you try adding it the way way it’s added here It works on my Android phone.


I tried that yesterday and it didn’t seem to be working.

I put it in one of them and still doesn’t work. Any other ideas?

Hey Megan,

Try this, In your content, add the following HTML markup where you want to display the SM sign:

<i class="sm"></i>

Then add the following CSS code in the Theme Options > CSS:

.sm:before {
    content: "\2120";

Don’t forget to clear all caches including your browser’s cache after adding the code. Let us know how this goes!

Hello Megan,

I have checked your page in my Android phone and it appears as square too.
Please use the HEX code or the HTML code:

Please let us know how it goes.

Hello There,

Please make sure that you have inserted a valid and correct code. I have checked your page and it seems that in some parts of the page contents, there are some broken html tags added particularly unclosed p tags. This might also affect the rendering of the elements.

For example:

<p class="man">For many companies, the last time they launched an organically developed, major new growth platform may date back close to their founding.  The success of operating at scale inhibits innovative growth internally and often leads companies to pay a premium and acquire their next growth platform; a risky venture in itself.</p>
<p>We imbed with our clients to help them innovate outside of their core with methods that mitigate risk.  We deliver transformational new product platforms that drive major, top-line growth.</p>

An orphaned </p> tag is added.

Please let us know how it goes.

I just looked in the code and in the Inspector and all the paragraphs are closed with < / p> tag.

I tested if I put a trademark instead of service mark after a heading it shows up. Just the service mark is not working?!?

Hi Megan,

To assist you better with this, would you mind providing us your wordpress admin login in Secure Note


I added my username and password.

Hi Megan,

To fix this, please change the service codes with <sup>SM</sup> Then add the code below in Theme Options > CSS

.our-solutions sup {
  font-family: "Prata",serif;

Hope that helps

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.