Revolution slider isn't loading

Hi Not sure why suddenly revolution slider isn’t loading. Any idea?

Hello There,

Thanks for posting in!

Could you please update to the latest versions?
Our latest versions are:

  • Pro theme 1.2.7
  • Rev Slider

This latest release contains fixes for several issues so be sure to check out the changelog (

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Please let us know how it goes.

Thanks for your reply. I have updated everything on the staging server but still didn’t work.

Hello There,

Your slider is working in the staging.

Cornerstone and WPEngine doesn’t really go along much. The Cornerstone builder takes place on the front end, in most cases WP Engine tries to cache its resources. This can cause stale data to be loaded. To resolve this, you’ll need to clear the site cache in WPEngine right after saving every changes you made in Cornerstone.

How to purge the site cache
You can use our interactive tutorial, “What should I do if I make changes and they don’t take effect?“, in the User Portal, or you can follow the instructions below.
Purging your site cache is very easy. You just need to know where the button is located:

    1. Long into /wp-admin/
    2. Click on WP Engine button located at the left top side.
WPE Plugin
    1. Click “Purge all caches.”
Finally, clear your browser cache and refresh your page. Once you refresh the page you should notice that the content has updated. If it is still not updating, you may want to consider contacting support by creating a support ticket.

To know more about WPEngine caching system, please check it out here:

Hope this helps.

The slider you’re seeing now is the one i have set. But the main slider on product ( now set on staging) isn’t working

Hi there,

Please kindly check the troubleshooting guide of the Revolution Slider, especially the section regarding the jQuery no conflict mode:

If you still have problems add a Test Page and add the Revolution Slider there. kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

tried almost everything. Added login credentials. Please let me know if you need anything else. Thanks

Hey @appsrex,

The issue is intermittent on my end when logged in. I’ve tried reloading several times and sometimes the slider loads sometimes it doesn’t. It doesn’t load all the time when logged out. There’s probably a third party factor causing this but I could not pinpoint where. Can you try creating a blank transparent slider and use the video background option of Slider Below Masthead feature in X? If that works, you could try adding in layers one by one while checking if the issue will occur again.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.