Revolution Slider gone, can't be reinstalled

Hey all,

a couple of months ago, Slider Revolution disappeared from my website (running Pro and WPML) so I tried to reinstall it by removing the plugin folder and then reinstalling it from the “Extensions” page. No luck. Despite the folder being gone, the install always gets canceled because the plugin directory “already exists”.
I tried uploading the plugin manually, but even that didn’t work.

I’m really at wit’s end right now and need this plugin to work. What can I do?
I’m on the latest version of Pro and all my other plugins are up to date.

Hello @christopherbolte_92,

Thank you for the details.

“already exists” means that the revolution slider folder exists in your plugins folder and it is corrupted. It could be a connection time out during the updates. The only way to resolve this is to log in to your FTP account and browse to the plugins folder wp-content/plugins/. You will need to manually delete the revolution slider folder. Once you have deleted the folder, you can now go back to Pro > Validation > Extensions section and ready to install the Revolution Slider plugin again.

We would love to know if this has worked for you. Thank you.

That’s exactly what I did but I still get that error. Tried deleting via FTP and then installing, and also tried removing and then uploading via FTP to no avail.

Hey @christopherbolte_92,

In that case, please give us WordPress Admin and FTP access in a Secure Note so we could investigate.


Hey @christopherbolte_92,

Your WordPress login page is broken. That needs to get fixed first.

The FTP credentials are working.


Oh, sorry, did you try /wp-admin or /wp-login ?
It’s working here.


Hi @christopherbolte_92,

I’m able to access the login URL but a bit slow, once loaded, it redirects to something like this

Then, upon inputting the answer, this appears

Tried it multiple times with the same result, could you try disabling that verification first then if there is any security blocking the access, please disable it too.


Alright, should be deactivated.

Hello @christopherbolte_92,

We have logged in to your WP site and the FTP. Are you sure this is the correct FTP directory? We have tried several times and it is not working for us. It seems that /WordPress_01/wp-content/plugins is not the correct plugin directory of your site installation. We tried to removed the revslider and even the classic editor plugins in the directory yet it still displays in your WP site plugins section. This clearly shows that the given ftp is not the correct directory of your installation. Could you please double check so that we can personally install the Slider Revolution plugin?

Thank you in advance.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.