Revolution Slider Breaking Cornerstone Preview

Our first use of revolution slider, which is nested inside a global block, is causing our homepage’s cornerstone preview to break. Our system has the necessary resources setup.

Hello Josh,

Thanks for asking. :slight_smile:

Please make sure that you are using the supported version of Revolution Slider. As of today the supported version is 5.4.8. Along with that please try out following:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  4. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.
  5. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Thanks for the reply.

  • I’ve checked my versions and we’re all up to date.
  • I deactivated all plugins but the problem persisted.
  • I removed the custom JS code we had, but that didn’t change anything.
  • There’s no way for me to remove all the custom CSS; its embedded in over two dozen global blocks as well as the theme and the page.
  • I am reaching out to our IT department about the htaccess and PHP memory.

OK, we’ve tried everything on our end. No luck.

Hi Josh,

Did you provide the credentials for the site that I have added in the secure note below ? If so, the login credentials seems to be invalid. If you’re referring to a different site, please provide us with your site URL to check.

In the meantime, also check your PHP version running on your server and make sure to use PHP v5.6.x or later to avoid incompatibility issues.


TL;DR: If you’ve got bullet navigation enabled, try disabling or changing the bullet style.

I was having the same issue. I was getting the following error and warning in the browser console:

cs-vendor.js?ver=3.3.6:10662 ReferenceError: title is not defined
    at Object.eval [as compiled] (eval at e.default (cs.js?ver=3.3.6:1408), <anonymous>:3:7278)
    at cs.js?ver=3.3.6:1410
    at cs-vendor.js?ver=3.3.6:10770
    at ao (cs-vendor.js?ver=3.3.6:10787)
    at so (cs-vendor.js?ver=3.3.6:10791)
    at Fo (cs-vendor.js?ver=3.3.6:10824)
    at Io (cs-vendor.js?ver=3.3.6:10820)
    at jo (cs-vendor.js?ver=3.3.6:10819)
    at Oo (cs-vendor.js?ver=3.3.6:10813)
    at ho (cs-vendor.js?ver=3.3.6:10807)
unable to apply patches ReferenceError: title is not defined
    at Object.eval [as compiled] (eval at e.default (cs.js?ver=3.3.6:1408), <anonymous>:3:7278)
    at cs.js?ver=3.3.6:1410
    at cs-vendor.js?ver=3.3.6:10770
    at ao (cs-vendor.js?ver=3.3.6:10787)
    at so (cs-vendor.js?ver=3.3.6:10791)
    at Fo (cs-vendor.js?ver=3.3.6:10824)
    at Io (cs-vendor.js?ver=3.3.6:10820)
    at jo (cs-vendor.js?ver=3.3.6:10819)
    at Oo (cs-vendor.js?ver=3.3.6:10813)
    at ho (cs-vendor.js?ver=3.3.6:10807)

I tried starting with a new blank Slider Revolution slider and slowly rebuilt my slider.

I finally identified that the “Zeus” bullet style is what causes Cornerstone to break and display the errors above. So after choosing a different bullet style (or turning off bullets), Cornerstone preview starting working again for me.

I also noticed that global slide layers cause the slider not to render within the Cornerstone preview. That’s a little annoying, but isn’t that big of a deal.

Pro theme version: 2.3.6
Slider Revolution plugin version: 5.4.8 (no other plugins installed at this point)

Thanks for sharing your experience, @ethode.

Running PHP version 5.6.38, so we’re good there.

Checked on bullets, which are not enabled, so that’s out.

Double checked the login information, and it is correct. You most likely got trapped in our login redirect problem. Please verify that the URL you’re attempting to login to is:


Hi @LDGThemeCo,

Assigning different slider fixes the issue, which means the culprit is coming from the content of your slider (not the bullet navigation this time).

Please backup the fault slider then delete its layers and slide one at a time while testing if the issue is gone. If it’s gone then the last slide or layer that you deleted is the culprit.


I deleted every slide in the slider and cornerstone preview still did not work. Please advise further.

Hello Josh,

Thanks for updating in! I have checked your homepage and there is a JS error present in loading the page. MapSVG plugin is having conflicts which may have halted the preview in Cornerstone. Could you please temporarily disable the plugin. And by the way, please provide us the name of the slider and the global block so that we can export it and import to our local testing server so we can test it ourselves.

Thank you in advance.

The original slider, which I deleted all of the slides from and is still causing an issue, is “sheetz-old-broken”. The copy of that, which still has its slides, is “QSR-sheetz”. The global block that calls the slider is “QSR-Sheetz”. Because this is a live, functioning part of our sales media for our company, I have “QSR-sheetz” active so that it is usable on the front end.

I have disabled the MapSVG plugin, however, that did not resolve the issue and cornerstone preview still will not load.

I’ve updated MapSVG to the latest version and the console errors are resolved. I’ve re-enabled the plugin. Please let me know if should be disabled.

After updating both the theme and MapSVG, the cornerstone preview issue has been resolved.

Hey Josh,

We are just glad that you have figured it out a way to correct the said issue.
It’s good to know that updating the theme and the plugins were the solution of the issue.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.