Record not found - WP with Revolution Slider

Hi, I use WP 4.8.1. with Revolution Slider and get this message: Record not found.

I use version and I did uninstall and re-installed the Revolution Slider plugin already. But there is no progress.

Theme X. RS version is Before updating this plugin RS was working fine.

Thank your for your help.

Hello There,

Thanks for writing in! Please make sure that Rev Slider is active. There are cases that after the update, it remains deactivated. Or better yet, please re install it manually. Please log in to your ftp and browse to the plugins folder. Delete revslider folder completely. Go back to your WP dashboard, X > Overview and re install the Revolution Slider.

Please let us know how it goes.

Thanks. I did follow your instructions, but the result remains the same.

Hi There,

In that case, would you mind providing us with login credentials so we can take a closer look? This error will occur if the slider we’re calling on the frontend doesn’t exist. Usually this happens when we install a demo and then revslider is not active yet. Thus on the demo download, revlisder is not able to download with the other content. Please provide following information:

Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials

All the best!

Hello @VDongen,

Thanks for providing the credentials. I have re installed Rev Slider and re activated it again. The slider is is working again.

Please check your site now.

Nothing has changed from my side, Record Not Found remains. I have removed cache and tried few browsers.

Hi There,

I clicked Edit page, selected a slider for above masthead, another for below masthead - saved- removed the sliders - saved.

It works now.

Hope it helps

It works, thank you.

Glad we were able to help :slight_smile:

I am having the same issue. I have deleted and readded the REV Slider with the same record not found error. All I did was change the pictures after applying demo content. I tried this on two wordpress installs with the same result.

Hi There,

Thank you for writing in, are you referring to this to this site? I’ve check all that site pages and did not see the error, please provide us the direct link of the page where we can see the issue.

Actually this error Record not found. means that the slider you set does not exist, what you need to do, is edit the page and re-set/re-select the slider.


The issue was not present because I had to disable the plugin. I have just reinabled it so you can see the error. I do not have the Rev Slider short code imputed on any pages on the site. When I disable the plugin everything works fine.You are correct the site is

Hello There,

To resolve this, please edit your homepage and find the Slider Settings: Above Masthead. You will have to disable the slider assignment because it is assigned to a non existent slider which is causing this issue. To know more about sliders and how it is integrated in the theme, please check this out:

Hope this helps.