Problems installing X demos

I have problems installing X demos. After installing and activating all extensions, I go to Design Cloud to choose the intended demo. By clicking on install button, it freezes and “Initializing…” step doesn’t go on, so no demos are installed.
I wonder if you could help me with this problem.
By the way, I’ve upgraded the Theme to the latest version.

Hi Hamid,

Have you tried clearing your cache after upgrading? Please also try disabling other plugins to check if it’s a plugin conflict. If you have done both and the issue is still there, could you give a temporary access to your site and put the credentials in a secure note? So we can investigate further.


I tried both ways, but they didn’t work and the issue still exists. Further more currently my site is on localhost.
I wonder if my license has problems?

Hello Hamid,

Thanks for updating in!

This issue usually occurs when you have exhausted your PHP Memory Limit, Low Max Upload Size or limited PHP Timeout Limit. These are just guessed. Simply go to X > Status, copy the results and paste it in your next reply. We need to check the server details of your localhost.

Best Regards.


Site URL - http://localhost/xtheme
Home URL - http://localhost/xtheme

WordPress Environment

Version - 5.3
Debug is on - No
Language - en_US
Is Multisite - No
Memory Limit - 512M

Web Server Configuration

Software - Apache/2.4.41
PHP Version - 7.3.11
MySQL Version - 5.5.5-10.4.8-MariaDB

PHP Configuration

Post Max Size - 40M
Time Limit - 120s
Max Upload Size - 40M

Active Theme

Name - X
Version - 7.1.2
Folder - /C:\xampp\htdocs\XTheme/wp-content/themes/x/
Cornerstone Status - Enabled
Cornerstone Version - 4.1.2

Active Plugins

  • Cornerstone 4.1.2


Click this button to check what CDN this site is using. - Check CDN

Hello Hamid,

You will have to increase your PHP memory limit. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

And you also need to increase your Max Upload Size and Time Limit.
Please check this link for the detailed instruction:

We would loved to know if this has work for you. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.