Problem with website

I recently installed x theme and i was using a free wordpress theme.

When i post a article in posts on word press, all my posts com up on the blog categories.

it a fitness blog and i have blog, recipes and products reviews but all my posts are going under just the blog on Nav bar??

How can i sort this?
John C

Hi John,

Blog listing page by default will display all your post. This is the post page you set on Settings > Reading > Posts Page.

This is a general wordpress settings, the same on all themes.
Now, you intend to display a specific category only, please go to Appearance > Menu. Edit your current menu, remove the blog page link and replace with the specific category you want to display.

Hope this helps.

Hey Lely,
Thank for coming back to me.
I have 3 main categories,
1 - blog which is all blog articles
2 - recipes
3 - product reviews

So i just need to remove blog page and link specific category/////but i still need the blog page because i have articles posted on this page like (17 articles)

Kind regards

Hi John,

I think we have a misunderstanding here. There’s a blog with all your articles, where these articles can be group. So in the heirarchy, blog is on top and it can have categories under it. So when you set a certain page as POST PAGE, it will display all articles regardless of categories unless you have specified not to display certain category. I think your recipes and product reviews are custom post types. Can you confirm? If it is a custom post type, that means default post page listing cannot do what you want. You might need to use ESSENTIAL GRID to create the listing page. This plugin can display default blog post and other custom post type available on your site.

Hope this helps.

Hey Lely,
This is my web address, this mite help you to see what’s going on!


i just need
1 - blog page with all fitness articles
2 - product review page with my product review articles
3 - recipes pages with my page

when i changed pages to categories(pages came up blank, like in cornerstone, not finished pages(categories)>>?

Hi John,

I might be wrong and you do have actually blog categories as shown on your sidebar:

The issue is you have permalink error. Instead of categories you have blog posts on the URL. It was causing an error. We might need to check your setup. Please share site credentials inside a secure note. That might be the answer on all of those 3 that you need. Category pages are controlled by a template and not by the builder.

Hey John,

I would like to go back from your initial post and answer your questions.

This is normal because the page that is set as the Posts page (please refer to @Lely’s screenshot) displays all the published posts that is added in WP Admin > Posts.

Since you created three categories in WP Admin > Posts > Categories, and you want to add them to your navigation area, you can do that in WP Admin > Appearance > Menus.

Find the menu that is assigned as the Primary Menu as that is the menu that displays on the site’s navigation area.

Once you found the menu, you should see Blog as one of the menu items. You can delete the Blog menu item then save the menu.

Now, you have to add the categories in the menu so that they will be accessible on the site.

To do that, you will have to add them as menu items. You will have to add the new items under the Categories option:

Select the categories then add them to the menu and save the menu. Once you’ve done that, you should be able to see them on the site as menu items.

If you want to read more about the Wordpress Menu, please check this link:

Hope this helps.

i’ve tried this and it still isn’t working???

HI John.

In that case, can please provide us with the admin access to your site in a Secure Note so that we can check your setup and see what you missed:

any update?

Hello John,

Thanks for providing the details.

I have logged in to your site but you did not do any of the suggestion that I have previously provided that is why you are not seeing any changes on your site.

Can you fix the error for my, its delaying me from launching my website

Please also note that this is not a theme error but more on the setup of the menu items since you mentioned you are not that familiar with web developer.

I will go over each item in your current setting and explain the items that you will have to change or add and please take time to read and apply the suggestions as the support we provide is limited to providing suggestions, answers, and solution but not to actually setup your website.

Firstly, the Blog page in the menu item is still the page that is set as the Posts page that is why it is still showing all the posts:

Next is your Recipe menu item which you have correctly added:

However, when you go on the website and click on the Recipe menu item, it links to the homepage. This is because of what you have set in the category base field of the Permalinks setting of your site:

This setting messes up the URL of the category index pages since there should be no spaces set between the category base setting and %20 is also invalid.

Lastly, the Product Reviews link:

Going on your site and clicking the Product Reviews link shows a blank page. That is because you still have it as the Product Reviews page which is a blank page. It should be added as a Category in the menu link as instructed in my previous reply.


Now, from your current setup - here are the things that you need to do:

#1. Remove the Blog, Recipes, and Product Reviews menu items that are in the menu:

#2. Go to the Add Menu Items area that is in the left of the menu settings then scroll to the Categories option then select the Blog, Recipes, and Product categories and add it to the menu.

#3. Save the menu

#4. Go to WP Admin > Settings > Permalinks then change the setting of the category base option. This is an optional field so you can leave it blank and remove the current setting. If you want to set it to something, you can change blog%20posts to blog-posts.

Once you completed the steps above, the Blog, Recipes, and Product Reviews pages on the site will be index pages of the post that are specific to those categories.

Hope this helps.

problem is fixed!
one more small issue

when i post as a link
the details that come up dont explain the blog page etc

it comes up as sliver tooth??? my home page

Hello John,

Facebook was using the cache version of the site. I have corrected it already by scraping the information from your site again using the Facebook Debugger. It is all good now.

Kindly check your site again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.