Problem with cornerstone content edit


When I want to edit a page in CS, it just goes to http://URL/x/#/content and not to the specific page i launched it on. When I then try to edit that page from there, it looks like its loading but nothing is happening.

Hi There,

Please check on Wp Admin| Settings | Permalinks and make sure it is set to post-name.

If that does not solve your issue, please make sure you flush the cache and turn off any cache plugins you have.

If the issue persists, please provide your login credentials in a secure note so we can take a closer look.


Hi There,

Thanks for the details.

I found the URL you have sent is not working. Here is the screenshot for the issue. I tried with two different network.
Can you please check.


please try again. it is working now

Hi there

Permalinks are set to /%postname%.html and I did not change this setting. I do not have any cache plugins.

the login credentials are posted in the secret note in my initial post

Thanks for your help

Hi There,

Unfortunately, your site is still not loading on our end. I have ask another support and we’re both seeing This site can’t be reached took too long to respond. In case you do have IP based blocking, please try disabling it for the mean time.

For me it works perfectly well

Your site won’t load on my end too.

It looks like your host have set some IP restriction. Please ask your host to disable the restriction so we could see your site.


I spoke to my host support.The page works fine

They would like to know from what IP address you trying from. Then they can check if it is blocked in the firewall.

Thank you in advance

Please ask your host to disable firewall for the time being.


They cannot disable the whole firewall as this is too risky.

Please indicate from what IP address you want to access the page so the host can whitelist it. If you cannot do that please indicate the reasons why not so I can share this information with the host


Hey @bakrona,

We could not give you a specific IP address because support members are located in different parts of world. If I give you my address now, another support member with a different IP could be answering your thread so he won’t be able to access also. Moreover, most of us use dynamic IP. With that said, we really need the IP restriction disabled so we could investigate.

For the meantime, please try out the solutions suggested at


The page is on a shared server so they cannot just disable the firewall. This will affect different sites and since I dont know exactly when you will look at the page, I cannot have the firewall disabled for a few hours.

So the page works fine. the problem is that if i am on a page and I want to edit it with CS, it first goes to http://URL/x/#/content/11306 and it seems to load but then the URL changes to http://URLh/x/#/content. From there you can chose the pages to edit but again, it looks like its loading but then in the end it does not

Hello There,

Thanks for updating in! I happened to check your site and I found out that there is a fatal error in the site. It appears that though you are using the latest Cornerstone version 2.1.7, your theme is out dated. Please update the theme to the latest version 5.2.5.

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Please let us know how it goes.

OK thanks for your feedback

Just to clarify:

  1. You were able to access the site? I need to give feedback to the host
  2. What do you mean by fatal error?
  3. How do I clar all caches? I do not use any of the plugins you mentioned
  4. I upgraded X but I still face the same issue

Hello There,

Thanks for updating in!

1.) I was able to access the site. Please see the secure note.

2.) Yes a fatal error occurred which is why you cannot edit in Cornerstone.

There is an undefined call going on which resulted to a fatal error. Please make sure everything is up to date. Out dated theme and plugins will results to an issue.

3.) Please ignore the cache if you are not using CloudFlare or any caching plugins.

4.) You still need to update other plugins installed.

Please let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.