Problem opening theme options

I am not able to access theme options in the site .Sometimes the theme options page doesnot open up but sometimes it does but When I reach the page which gives me otheroptions it gets stuck there


I have tried a lot of things like reinstalling the theme after deleting it completely, disabling a lot of plugins etc.

Hi there,

Please make sure to check for the following first:

  • We’d recommend that you increase your memory allocated to PHP if you haven’t done so already. To increase it, please edit your wp-config.php file and insert these lines:
    define( 'WP_MEMORY_LIMIT', '256M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );
  • If the issue is still there, please make sure that you have everything updated to the latest version especially for X and Cornerstone. You can find more info about the support versions of X and its bundled plugins here.

  • If you are still seeing an issue, please try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes!

I have tried all of that.
still the problem persists
Thanks for the answer

Hi Sarina,

Since you’re using CloudFlare, try clearing it’s cache by login to your CloudFlare account. Also disable CSS and JavaScript autominifications under Speed tab and test your issue again.

Also you need to check the PHP version running on your server and make sure to use a PHP version like v5.6.x or later to avoid incompatibility issues.

If you’re still having issues, please provide us with your WordPress credentials along with your FTP credentials in a secure note to investigate your issue further.


Hi Sarina,

These are the errors that the site is throwing when accessing the Theme Options (actually with your Cornerstone as well) I’ve seen these errors a couple of times and most of the time (if not all), these are related to caching and/or security. I notice your site is under CloudFlare, please directly login to your CloudFlare’s dashboard and do the following (not on the CloudFlare plugins):

Exclude the Theme Options and Cornerstone builder from being cache by using this pattern ** follow this article on how you can add a page rule (exclude) on your CloudFlare account.

Next disable the CloudFlare’s JS and CSS minification option, read this article., X theme’s JS and CSS files are already minified so you don’t need this feature.

Lastly and most importantly purge everything from the cache, also clear your browser’s cache to make sure that there is no cache involves when you load your pages.

If the issue still persists after this, please try turning off your 2 security plugins (All In One WP Security and Wordfence Security)

Let us know how it goes,

thanks for the review
Can you be a little more specific
I already have the page rule

Summary cache bypass
to exclude theme options should i replace this with

update : the problem is solved with the change in the page rule

Glad it’s working now.

Please check the screenshot.
the page load is 15 secs.
I deleted and reinstalled cornerstone - it solved the problem a while back 'but this time nothing happens.
It is not the above site.

Hello There,

Is it the same domain? Have you installed a caching plugin like Swift Performance Lite plugin? Please clear all your caches and make sure to regenerate the minified JS and CSS files. And it is not helping, please provide us the correct url of the site (including the WP access only if necessary) so that we can check it.

Please let us know how it goes.

Thanks for the prompt reply
It is not the same domain
I have swift pro installed
i have cleared swift cache ( cloudflare cache is not cleared )
I had earlier opted to Merge CSS/js files to reduce number of HTML requests in the plugin but later opted out of it seeing that there was some problems on the front end of the site

how do i regenerate the minified js and css files

Hello There,

Where you have merge the JS/CSS files? The JS/CSS files in the theme is already minified. Please do not minify the files. You may have minification option in the cache plugin and the CloudFlare > Settings > Speed tab.

Clearing the cache will remove the mnified files as well. It will eventually regenerate once the new cache is loaded.

Hope this helps.

I have removed the minification some days back
so it must have regenerated already right?
there is no minification done on cloudflare as well

but my problem with the font still exists after clearing the cache

Edit : I just found this page on your site :
which of this is relevant to me

Hi @sarinata,

Another staff here and trying to access your site admin but can’t, I’m blocked by your site’s security.

Those fonts don’t exist anymore as they now have a different naming. Example, this works https://**********.com/wp-content/themes/x/framework/fonts/font_awesome/fa-regular-400.woff

There is something in your site that is still requesting the old fonts that aren’t available anymore. Would you mind providing your FTP and CloudFlare login credentials as well? I like to verify if you have older scripts too (not updated files).



I have reinstalled the theme after deleting it and still the problem persists
Can you check for further details

Hey Sarina,

I just checked your site in Pingdom again and there is no Font Awesome missing font (see secure note). It’s also the same in dev tools. It looks like the cache has been cleared in Cloudflare. When you checked last time, you might have tested immediately after clearing cache that is why you still see the error.

Please note that we do not have support for optimization issues. If this persists, please clear all caches and uninstall your caching plugin completely. We would also need that you disconnect your site from Cloudflare because we need to know if the issue is coming from the theme. It’s also quicker to test where the issue is coming from once you bring back optimization systems one by one.


Thanks for the reply
Seems like the font awesome error is not there any more
Maybe when I reistalled the theme it got replaced but somehow when I tested after this also it did not show up

You’re welcome, Sarina.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.