Pro v2.2.2: Errors when enabling custom headers

Updated to Pro v2.2.2 and if I attempt to assign a header to any pages (or “all pages”), the follow error is presenting:

The preview could not load. This is most often related to a plugin conflict or aggressive page cacheing. Checking the developer console for errors could indicate what went wrong.

Origin URL:

Preview URL:

when attempting to edit the header, or to edit other pages. This seems to be independent of PHP version, etc.

Hi There,

in general is a generalized error message that can mean one of many things. Please make sure to read the following thoroughly and follow all steps outlined.

The message can be caused by the following:
Incorrect setup of SSL. If you have an SSL certificate on your site. You should have the WordPress Site URL and Address URL settings set to HTTPS if you are loading the builder via HTTPS. This can be checked via your wp-admin > general > settings. If you aren’t using SSL you can ignore this step.

Caching. If you have a caching plugin activated or any form of server side caching please disable it to test for any possible conflicts. If you have server side caching or aren’t sure if you do, your host should be able to advise of this and disable it for testing purposes on your account.

Cloudflare. If you are using Cloudflare please disable this for testing purposes. Cloudflare by default enables an auto minfication function to compress the JS and CSS files of the theme. As the theme already serves minified files, re-minifying said files only causes to break the entire site.

Custom code syntax error. If you have a child theme, please enable the child theme and check if the issue still exists. If you have entered any custom JS or CSS into their respective editors. Please review the code for any syntax errors. A mis-placed semi-colon or a missing bracket will cause the issue you’re seeing.

Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If you could please try the above and if you still have the issue we’d be more than happy to assist.
Please provide following information:
Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials
    All the best!


I’ve updated to v2.2.3, still seeing this issue.
SSL is configured properly
Not using caching or cloudflare
no custom code
tried resetting .htaccess file, same issue.

I’ve created a secure note with the requested credentials.

Hi There,

I checked your website and can confirm the issue.
There is some JS file which failed to load due to PHP memory limit.
Please follow this two steps and let us know the result.

  1. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

  2. Follow the steps mentioned in this article:

Hope this helps!

I’ve followed the steps outlined in both of the links, still not working.

Hello There,

The given credentials because it is not working for us. It seems that the username is invalid. We have logged in to the ftp too. It works but it does not the correct directory of your installation because it is empty. Could you please update the credentials make sure that it is correct so that we can log in and investigate this issue further.

Thank you in advance.

I installed the stability release version (2.1.6) after putting a rather large dent in my desk from banging my head against it in frustration. This version had worked previous, and lo and behold, it worked now with no issue.

I proceeded to update to 2.2.4, and everything seems to be functioning properly. ¯\_(ツ)_/¯ I

We’re glad it’s working now.

After installing woocommerce and activating it, it no longer works.

Hi There,

Your FTP account is showing blank.

Could you please provide us with your root account instead?

Many thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.