PRO - Update on multisite breaks network

I’m running a multisite network with about 40 sub-sites, almost all of which are using child themes of either X or Pro. The latest version of Pro didn’t show up in my updates, and when I tried to manually update it via FTP anything using a child theme of Pro stopped loading entirely. I attempted to do the same thing with a site not using a child theme, and ran into the same issue. Is there anything special I should be doing to update Pro on a multisite network, or is there any help you can offer in getting the latest version up and running?

Hey @sevenagesdesign,

It could be that you have a custom code in your child theme that caused the issue. Please also note that if you’ve overridden a template, you will need to take a look at the recent parent theme file and update your child theme templates accordingly.

Please also detail what exactly was broken.

Also give us WordPress Admin and FTP access for this case so we could check your setup.


The sites that used the Pro child theme were completely unreachable. I was given a “This site is unavailable” browser error. I was unable to access either the site or wp-admin. I attempted to disable as many plugins as I was able to without interfering with the other websites on the network. I tried to install the theme manually multiple times, and also tried to install it to a site without a child theme, which also became entirely unreachable. I’m attaching the WordPress Admin info and FTP to a secure note. Thanks for the help!

Hi There,

Thank you for the credentials, but it seems you forgot the hostname. Please clarify how did you do the manual update, did you rename the old Pro folder first? Or did you just do an overwriting of the Pro folder? The recommended way is to rename of better to delete the old pro folder first and then upload the new one.

I saw another version of Pro 1.1.0 on your site, would you mind deleting that version to avoid conflict with the new version.

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Let us know how it goes,

Oh wow, sorry about that! Completely forgot about domain. I’m assuming you found it from the FTP information, but it’s - the same for FTP access. To do the manual update, I deleted the old Pro directory (after downloading a backup of it) and uploaded the new one via FTP.

I’ve removed the X Pro 1.1.0 theme and cleared all caches as you recommended and attempted to update Pro again. I’m running into the same issue where every site using either Pro, or a child theme of it, is entirely unavailable. Now that I’ve seen the error page again, it’s a 500 error - and I’m unfortunately not seeing any further information in the console that I can pass to you.

Hello @sevenagesdesign,

Thanks for updating the thread.

I see that on website you have Pro Theme version 2.0.4. When checking the front end website seems to be working fine even after activating the child theme. Please do the following to update to Pro 2.3.8:

  1. Login to FTP and under /wp-content/themes/ rename existing Pro theme folder.
  2. Download latest version of Pro Theme from members area and extract the zip file.
  3. Upload extracted Pro folder under /wp-content/themes/.
  4. Check the backend to verify things are working fine and the version information under Pro > Validation > Installed Version.
  5. If everything is working fine, you can delete the old Pro Theme folder that was renamed.

Please let us know how it goes.


I just tried to update the theme the way you described. I downloaded a fresh copy of Pro 2.3.8 for this. I connected to the server via FTP and changed the name of the theme directory from pro to pro.2.0.4. After I did that, I uploaded the new pro directory to the site. I encountered the same 500 error as I was in previous attempts.

Every site on the network using Pro or a child theme just refused to be reached. I’m unable to get to the Wordpress admin panel when I install the updated theme due to the 500 error. I need to revert to the original installation every time to get it working.

Sorry for being a hassle, but I’d really like to get the theme updated as soon as possible.

Hi There,

I meant hostname, don’t worry I figure it out its s

Ok lets try updating this way, first, please add a WP DEBUG on your wp-config.php file for error logging in case the error happen again will get a clue what is causing it.

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

While you’re at it, lets increase the Increase the PHP Memory Limit

Now do the updating like this, do it in cPanel’s File Manage its much faster. Comment out or delete the custom functions that you have on your child theme’s functions.php file first.

Then lets not delete or rename the Pro folder, lets delete the files that is inside it, then replace those files with the files of a fresh/updated copy of PRO, you can download a fresh copy here.

The idea is to keep your current pro folder, but replace its files with fresh and updated copy.

Remember to clear all your caching features (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Let us know how it goes,

I’ve increased the PHP Memory Limit to 1G instead of 512M. This time around I tried two separate methods of updating, both with different results.

Method 1: I removed the contents of ./pro and uploaded the new theme files into the directory. Doing this caused the 500 error that other methods were causing.

Method 2: I left the original contents of ./pro alone and overwrote them with the new theme files. This allowed the sites to load, but the Pro Editor didn’t load at all. It stayed on the loading icon for the better part of 15 minutes before I pulled the plug.

I’ve also enabled the wp debug and logs. The old theme is currently restored, as I can’t have the sites down with the new theme files not working.

Hi Seven,

Maybe the installation isn’t complete and the older file may still remain if the same but new file is not copied or installed. Though, I checked and the builder works okay, may I know which specific page and section isn’t working?


The builder is working now because I needed to revert to the old version of the theme (currently working on a project and can’t have multiple days stall because of this). I’ve ensured multiple times that all old files are removed and new files are added. I’ll give it another go and hope for the best. If it still doesn’t work, I may need to look into other solutions that won’t break all my sites while updating. If I’m able to get it to work, I’ll post an update here on the steps taken.

Hello @sevenagesdesign,

Yes please let us know how it goes. And still if that does not work for you, please give us the permission to do the manual updates for you.


Unfortunately, I still haven’t been able to resolve this issue. Please do the manual updates for me. I’ve tried every method of updating I can think of and nothing is working. I’m at a loss. I’ve made a backup of the current theme files (Pro 2.0.4) just in case those need to be restored. I just need to know when you start so I can stop working on what I’m doing.

Hi Seven,

It’s a hosting environment issue, or could be cache. Please check the error in the secure note.

It says the the Cornerstone_Code_Editor class is not found or not-existing, it’s true because it’s now named Cornerstone_Control_Code_Editor. The weird part is nothing on the latest code that still calls for Cornerstone_Code_Editor, it’s from older version of theme. This means, the code running from your site is still old even if it’s already overwritten by the latest one. Perhaps you host environment has object or memory caching? I recommend toggling that off for now while we’re testing. Then let us know.


Okay, I feel foolish now. I apparently forgot that I installed memcached when I spun up the server. I flushed that and removed it (didn’t intend to keep using it since I changed my server structure), and now everything is working properly. Sorry for all the trouble, and thanks so much for helping me get to the bottom of this!

Hi There,

Glad things sorted out on your end now.

Have a nice weekend,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.