PRO Error message: The preview could not load due to the iframe response being incomplete. This is most often related to a plugin conflict, or customizations introducing a PHP error

Been looking through all related posts, but none of the solutions (increase memory, enabling wp-debug) mentioned there did work. The error message comes up at the header and footer builder, but not while editing a page.

My guess, it’s because my webspace is connected to an external domain (the domain belongs to a client) via A-Record… could that be and how to solve that?

Best regards.

Hi there,

I am not sure regarding the A record, the important thing is that the home_url and website URL should be the same in the Settings > General options.

I suggest that you follow up the steps mentioned in this article:

If you still have problems kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

You will need to tell us exactly the steps we need to take to hit the error, and if the error is site wide or only for one page.

Thank you.

Thanks for looking at it at the weekend :slight_smile:

Both URLs are the same and I did a fresh clean reinstallation of wordpress… no plugins installed or activated.

I’ve added a secure note to the initial post.

The error message pops up, when trying to edit a header or footer via Pro > Launch.

Hi there,

I tried that too with no success even by changing the theme name. Would you mind providing your FTP login credentials as well? And are you on shared hosting? I noticed some varying performance everytime I load your site.


It’s a shared host I usually just use for development.

FTP login is in the secured note.

Hi there,

Unfortunately, the credentials are not correct. Please provide the latest one.

Command: PASS ************* Response: 530 Login incorrect. Error: Critical error: Could not connect to server


Oops… my bad.
See below.

Hello There,

Thanks for the updates. I was wondering if you did anything to change your settings. I have tested Cornerstone in your site and seems no issue has been encounter. I was able to edit the page in Cornerstone and I even created a test page.

Please see the secure note for the test page.

As I wrote, it’s not while using Cornerstone to edit pages. It’s when I want to edit a header or footer via “Pro” > “Launch” > “Header” or “Footer”. :slight_smile:

Hey There,

Sorry for the confusion. I went ahead and investigated the issue. I edited your wp-config.php to enable the debug mode. keep on testing the headers and footers and I can confirm the issue. It is not opening or loading. I have check the error logs and it seems they are nowhere to be found. Is error logging disabled by your server? If you wouldn’t mind, please contact your hosting provider and ask them about error logs and where we can find them in your server? We need to check the error logs for any errors generated by the theme or the header/footer builders in your site.

Thank you in advance.

I tested some methods to activate the error log, but no success. Going to contact the hosting provider on monday. Currently I’m developing the site within my dev environment and hope I can migrate everything to the final webspace (always worked so far). Once everything is set, I won’t need the header or footer builder to work on the life-server.

So far X and Pro worked great with many of my projects.

Thanks. Let us know how it goes with your host. Also, in the meantime, you can try out other web host to see if it works because if it does, then the issue could be with your current host. Some host like offer free dev site you can test out.

The test migration from my development server went well… all content and settings are correct, just… that now at the final domain not even the pages are editable with Cornerstone (same error message as with the header/footer builder before).

I noticed, that the origin and preview URL are not exactly the same:

The ending slash is different. Does it matter and may that be the reason and how could that be fixed? Maybe an issue with the A-records?

Edit: The pages are at least editable when switching to the skeleton mode.

Hi there,

The ending slash does not matter and the URLs are identical, that should not be the problem cause. As you are using a fresh installation of the WordPress and the theme this should be related to the hosting service provider.

I suggest that you install the WP ServerInfo plugin and then activate it. Go to Dashboard > WP-Server Info menu and check the PHP Memory Limit. It should be at least 256, or even better 512. Try to increase it to 512.

The other thing is the PHP Script Execution TIme if it is 30 you need to contact your hosting service provider and ask them to increase it to 300.

The other point is the mod_security rules, the hosting service provider should exclude the builder URLs from that rules. So it should be something like this: HTTP://* this will ensure that all the /x/ folder and subfolders will be excluded from the mod_securoty rules. For more information:

The other point is the version of the PHP, Make sure that it is 5.6+ or 7.1+

Finally, I suggest that you move the same website to your local machine and test the case and see if it works, if yes then you will be sure that the problem is from the settings or a limitation of the hosting service provider.

Thank you.

Thanks. Going to check all the points you mentioned.

Staging and development use the same PHP (7.1) and both directories are at the same server, just that the staging directory is on the root level (eg. root/staging/) while the development directory is inside another directory (eg. root/dev/development/) and it works all fine at the development directory. Both server info from the wp-serverinfo plugin are the same.

Best regards.

You’re welcome. Let us know the results.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.