Pro Editor Very Slow

Working on a one pager. Now when i click an element to edit and scroll its in the settings of it, its very slow and halting.

I’ve done past tricks like increase php memory to 500mb via my provider and changing it in wp-config but it doesn’t seem to be fixing the issue.

What can i do to fix this?

Hello @JDRDigital,

Thanks for asking. :slight_smile:

Please do the following general solutions because it needs to be done by you.

  1. Please make sure that you are running PHP 7 or later on the server as running old version of PHP can have potential issues. You can refer following document for server requirement

  2. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  3. Clear all caches including browser cache then deactivate your caching plugins and other optimization plugins.

  4. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  5. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  6. Remove custom CSS, Javascript and templates.

  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

If nothing helps, please give us WP Admin and FTP access in a Secure Note.


Hey @Prasant

Thanks for the tips?

How do i go about doing steps 3, 4 & 5? I’m using jetpack as my CDN also?

How do i test for plugin conflicts? I’m only using plugins that were included in the Themeco packages.


Hi there,

Step 3 is valid if you have a cache plugin installed, if not just skip it.
Step 4 is mostly about the CloudFlare, but for Jetpack you need to contact their support to proceed with disabling the CDN temporarily for testing reasons.
For the Step 5, just deactivate all plugins event the ones that are bundled with our theme and check the case.

If you still have the problem of the Pro Editor being slow kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Also, give us the name of the page to test. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.