Preview Unresponsive error

Hello, I am a fan of the Themeco Pro theme, however pretty frequently I receive error messages indicating “The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.”
I have deactivated all of the plugins, there has not been page cacheing on this staging site. I am running php 7.2 and have tried 7.0 and 5.6. I have tried changing to the X theme and deleting and reinstalling the Pro and plugins. I have the most up to date WordPress and Pro theme. There are random times when the preview works but mostly this error displays.
The site is running on an Apache Dedicated SSD Webserver running Easy Apache 4 and whm/cPanel.
Surely others have received this error. How do I make the preview work?
Thanks in advance, Jon

Hi Jon,

Thanks for writing in! First of all, please go through the points below.

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Go to X > Settings and click on the Clear Style Cache button.
  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  6. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

To further narrow down your issue, please install the following plugin ( activate it and then head over to Dashboard -> WP-Serverinfo section.

Then check the following server configurations.

PHP Version - We recommend PHP v5.6.x or higher to avoid incompatibility issues. I know you have done this step but just mentioned it.

PHP Memory Limit - We recommend PHP memory limit of 512 MiB. If you see a value below than that, please refer to our guide [here](Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.).

PHP max script execution time - We recommend the value of 120 or higher (300). Here’s how to increase that value (

if you’re still experiencing this issue, please provide us with your WordPress login credentials in a secure note to check your issue further.


Update, I did all of those things and now the preview loads when I use Chrome instead of Firefox. I don’t know if it would have worked properly in Chrome before increasing the time out and memory.

So, I will use Chrome when working on this site for now on.

Thanks for all of your help. Pro is my favorite Theme. I have 8 licenses for it and am learning more with every website.

Hi Jon,

Thank you for using PRO, If the issue was the memory limit then it would have the error on Chrome as well. More likely this is a browser (Firefox) caching related issue.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.