Preview could not load ... tried some already mentioned solutions but didn't work

Hi,

I have the PRO theme and got the message: "The preview could not load. This is most often related to a plugin conflict or aggressive page caching. Checking the developer console for errors could indicate what went wrong."

I tried to deactivate all non-Themeco plugins and it was still the same. I looked in the developer console and it says: "Failed to load resource: the server responded with the status of 500 () and preview-frame update-aborted::

Then I cleared the style cache but still nothing. Then I changed the wp-config.php file to increase the PHP memory to 512 MB and still nothing ...

What else can I try?

Thanks,
Matic

Hi Matic,

Thanks for reaching out.

It could be a security issue as well and the request is being blocked. Given that you already did the troubleshooting then I like to test it too and see what triggers the 500 error. Would you mind providing the following information in the secure note?

1) Site's URL
2) Admin login credentials
3) CPanel/FTP login credentials

Thanks and let us know.

I've added the info in the secure note.

Hello Matic,

Thanks for providing the details.

I have logged in but I was not able to do some checking because the user you have provided has limited access to the site.

Kindly set the user as an admin user so that we can check your site.

Thank you.

Hi,

sorry, I have forgotten to change the role. It's fixed now.

Hey Matic,

What page is having this issue? I checked the existing pages and they're not using Cornerstone so I create a test page and Cornerstone works there.

Thanks.

Hey,

the test page you have created works also by me. But if I want to create a new header from a template like "hero" the preview doesn't work. The same when I try to make a new footer.

Hi Matic,

The FTP credentials provided did not work, please check.

In the meantime, please contact your hosting support and ask to deactivate the ModSecurity, then check your homepage in Cornerstone to see if that resolves the issue. If it does, since deactivating ModSecurity is not recommended, request to enable it back and unblock/whitelist only the URL below.

Cheers!

Hi,

have changed the FTP settings, now it should work.

For ModSecurity I'll update you when I know anything.

Hey Matic,

The FTP credentials still doesn't work.

While you're waiting for the reply of your web host regarding ModSecurity, you can temporarily work with building a Pro header by assigning the header to any page except the home page. You can assign it globally after you're finished.

Hope that helps.

Hi,

changed the FTP access, please check.

What if I want to make a header for the homepage? Assign it to random page nad then when I'm finished reassign to the homepage?

Hi Matic,

I tried to access the FTP and I still could not. Would you please double check to see if you can access via FTP and port 21?

The reason that we need the FTP is to go to wp-config.php and enable the debug mode, so instead of seeing the Error 500 we will see the actual error behind the seen.

Just to give you context the Error 500 is an Internal Server error and it is 100% related to your server and not the code of the theme. But to be able to know what capability of the server is causing the issue we need to have more information and enabling the debug mode will let us know.

I suggest that you follow up and enable the debug mode yourself. Here is how:
https://wordpress.org/support/article/debugging-in-wordpress/

We also need to know about ModSecurity. What was the hosting service provider response? ModSecurity is one of the common hidden reasons of error 500.

Thank you.

Hi,

I've added an alternate server ... please check. I've also enabled the debug mode in WP.

The screenshot of the error is attached

Hi Matic,

What do you mean "added an alternate server"? please clarify. The login credentials you provided above are not working anymore, please check.

Yes, that might work for now so you can build your header/footer.

What did your hosting say about the ModSecurity? Request to disable it for a while and see if that resolves the issue. If it does, since deactivating ModSecurity is not recommended, request to enable it back and unblock/whitelist https://maticbrdnik.com/pro/

Thanks,

Hi,

there are two ftp servers in the note. One is ...ftp.maticbrdnik.com the other is cpanel-14.controlpanel.si. Have you tried that?

For ModSecurity I still don't know anything ...

Hi Matic,

Another support here. I can see the site is totally down. I tried to login using 2 different FTP host provided but I cannot connect too. To make sure this is not an issue on my end, I asked 2 more support that is working, and both of them cannot login via FTP. The error is this:

Connection attempt failed with "ETIMEDOUT - Connection attempt timed out".

Hi,

the site was down because of the WP Debug mode. Anyhow it's off now so it works again.

When ModSecurity is off the preview works though. So I should just whitelist maticbrdnik.com/pro?

Cause in the beginning the preview worked well, I started getting these "cant' load preview" messages after a while ...

Hi Matic,

Yes, please whitelist https://maticbrdnik.com/pro/

This isn't something we can fix on our end. From the times we've seen it it is because the size of the POST request is too large and unusual so Mod Security rules block it. They will need to adjust their configuration to get things working. Common solutions that worked like whitelisting specific rules.

Thanks,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.