Post Title Icon will not save as off

Pro Theme, Icon Stack > the Post Title Icon option will not save as off in the Icon setting under Theme Options. I know it’s saving the options because if I turn on Standard Post Custom Colors and save, the change takes affect. If I turn off Post Title Icon and click save, it shows as off, but if I leave and come back it’s on again, and the change never takes affect on the posts, and yes I clear the cache.

This is the only way I can get it to not show up
h1.entry-title::before {display: none;}

If I turn it off, save, refresh page, it’s on again. Pretty strange.

Hello There,

I couldn’t replicate this issue on my end. Please follow up the steps below:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.

  2. Go to X > Settings and click on the Clear Style Cache button.

  3. If you’re using a CDN(ex: CloudFlare), please clear the CDN’s cache and disable optimization services. For the CloudFlare you also need to follow the steps below besides the developer mode:

  4. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. Remove custom CSS and Javascript from the options or Child Theme and test the case.

  6. Increase the PHP Memory Limit of your server. Click here for more detailed information and how to increase the PHP memory limit.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Pro Theme… not X, it’s literally the first two words in my original post. Just added it to a second site on a brand new Cloudways VULTR Server, fresh install, fresh everything, same exact issue.

Hi @jsowers897,

I saw the similar issue and it’s due to database caching, and I’m not sure how your host manages it. Would you mind providing your site’s URL and admin login credentials in a secure note? I like to confirm and see what’s going on.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.