Portfolio Pagination Links

Hi there,

I’m having trouble with the portfolio section of my website. I currently have it set up with 12 posts per page. Currently, I have 13 portfolio posts. When I use the pagination navigation at the bottom, page two leads to a 404. Do you know what could be happening?



Hi @iccwebadmin,

Thank you for writing in, please navigate to Settings > Permalinks and just re-save it without changes, so your Permalinks will be reindexed.

Let us know how it goes,

I’m still having no luck after saving the permalinks twice. Do you have any other suggestions?


Hey @iccwebadmin,

Under the Portfolio Settings of your Portfolio page, please try setting Posts Per Page to -1 to disable pagination.

This issue could also be coming from a third party plugin. Also please try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If both suggestions does not help, please give us WordPress Admin in a Secure Note.


I figured out the issue. Under Theme Options > Portfolio, custom URL slug. I had filled out the slug as the same name my portfolio page.

Once I removed the custom slug and saved it the pagination started working. I guess when I set up the portfolio originally I thought I had to fill out that field as well.

Hello @iccwebadmin,

It’s good to know that you have figured out the cause of the issue. And yes, most of the time, the custom portfolio slug when left bank or insert an incorrect slug will create an Error 404.

If you need anything else we can help you with, don’t hesitate to open another thread.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.