Portfolio layout changing between pages

Hey there. Portfolio page layout is different at http://www.tt-360.com/projeler/ and http://www.tt-360.com/projeler/page/2/ why? How can I correct this?

Also, page title changes in pages more than 2 (“Projelerimiz” on page 1 and “Portfolio I Sayfa 2” on page 2) and I want to translate “page” in the adress bar to Turkish equivalent “sayfa”. How can I do these?

One last thing. How can I translate “All” into “Hepsi” ? Adding a code snippet to functions.php apparently changes all “All” letter groups to “Hepsi”. I also tried using the *.pot files, translated & renamed them as they should be but for some reason the theme/wordpress doesn’t use them.

Hey @TT360,

Regarding the layout issue, I tried to replicate this in my test sites but the layout is the same in the 2nd Portfolio Page so this is unlikely an issue with the parent theme. It’s probably due to a customization in your child theme. Please switch to the parent theme and check if the issue persists. If this fixes the problem, please consult with a 3rd party developer to fix what’s causing the issue because as you might already know, fixing customizations is beyond the scope of our support.

Regarding the “All” word translation. It should be translated using the cornerstone Text Domain. You can find the pot file in wp-content\plugins\cornerstone\lang. You can choose translation methods in our Theme Translation doc.

For ease of translation management, I’d just suggest using the Alternative Upload Method mentioned in the doc. That means you upload the translation in wp-content/languages/plugins and prepend the cornerstone Text domain to your .mo and .po filename.

Only if you still have problems with the layout after switching to the parent theme, please give us the following details in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

Hope that helps.

Hey @christian thanks for your reply.

Regarding translation, I did everything written at https://theme.co/docs/theme-translations and now I have “Hepsi” instead of “All” thanks a lot.

Regarding portfolio page layout problem, under theme options > blog > style > masonry fixes this a bit, but the column number can’t be more than three (even though I have options up to four for the first portfolio page), so there’s again a layout change which is directly related to the theme, not my customisations. I’m leaving the style option as masonry for you to see it.

Secondly, second page assumes I have 10 posts in first page, so it displays posts starting from 11th. This is another bug of the theme, because I set it 12 posts per page at the portfolio page setup. // EDIT: Fixed this by a setting from JetPack plugin. Though, I shouldn’t need a plugin to fix this.

But my problem with the page title (“Projelerimiz” on page 1 and “Portfolio I Sayfa 2” on page 2) still exists. This is another problem with the theme.

Hello @TT360,

Thanks for updating in!

You are having the Portfolio page issue because your “Projelerimiz” is using projeler page slug which is the same as the portfolio custom URL slug in X > Theme Option > Portfolio > Custom URL Slug. I went ahead and changed the page slug to projelerimiz. You should now have a working Our Projects page both the first and the second page.

Please see the links in the secure note below.

Hey @ruenel, thanks for your reply. I went ahead and made some more changes, now it’s working well.

There’s two more problems. First; when I want to filter our projects and click on a category name on page 1, it can not fetch the projects which are on page 2 or more. It’s not rational to filter portfolio items only for the page displayed, it should filter all portfolio due to the category and re-create pagination if the item number exceeds “X posts per page” setup. Right?

A smaller problem is there’s no space before category names and after the slash (/). How can I fix this?

Merhaba @TT360,

The category filter for the portfolio items are set to function as a live filter. It will only filter the items that are present on the page that is why you are not seeing all the items. Since that is how it functions natively in the theme, changing that feature will require some customization which goes beyond the scope of our support.

Please add this code in X > Theme Options > CSS:

.option-set .x-index-filters-menu>li:after, 
.option-set .x-portfolio-filters-menu>li:after {
    margin: 0 8px;

Hope this helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.