Plugin Google Analytics

Good Morning,

I have a problem activating the google analytics plugin, it gives me the following message.

I realized that when the plugin is active it does not load the “Media” for example …

Notice: Undefined index: tco_google_analytics_code in /usr/home/ on line 50

Hi Mauro,

Please login through FTP then go to wp-content/plugins then delete the google analytics directory that is in there.

Once deleted, go back to the admin area then reinstall the plugin from the X addons.

Make sure to add only the analytics ID in the ID field of the plugin settings.

Hope this helps.


I have made the steps and keep giving the same error …

Hi Mauro,

This is a known concern. But, they’re only PHP Notices and along with PHP Warnings they are not errors. It would of course be nice if all notices and warnings will be eliminated but that won’t be feasible due to the fast improvements in PHP. They only notify and warn developers that this should be addressed for future versions of PHP.

The notices are related to the empty fields of the extension.

Filling them would eliminate the notice.

If you’re in a live site, it’s recommended that you turn debugging off or output the errors in an error log mainly for security reasons. You can follow the Example wp-config.php for Debugging at


The debug mode is disabled. But I still do not understand why in the other 10 websites that I have with PRO does not show me this error and in this one … I need to activate google analytics!

Hi Mauro,

In that case, please please provide us with the admin and FTP access to your site in a Secure Note:

Good Morning,

I enclose the access credentials in the secure note …

Hi Mauro,

It seems to be an admin credentials, we would like to request the FTP login credentials as well. We’ll try disabling the error logging through wp-config.php


I put you on the safe note the credentials you request…

Hi Mauro,

Thank you for the FTP credentials, I did check your wp-config file and WP_DEBUG is set to true. Please set that to false.

WP_DEBUG is set to false by default, maybe you only have set this true only to this site. Also, please check the versions of WP, THEMES, and Google Analytics on those sites.



Thank you!!

You’re more than welcome, glad we could help.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.