Pb with text over slider on mobile


I have a slide element (slider revolution) with some text (text element) going above it. It works fine on desktop, but the slider doesn’t go below the text element on mobile. Moreover, it is not possible to scroll-down on mobile when trying to do it on the slider.

How can I fix it?
URL: https://neowebsite.io/ (first section)

See below, showing where the slider starts (when it should be at the very top of the page):


Hey Antoine,

You have the disable scroll on mobile enabled. Please disable it under the Scroll Effects settings.

As for the alignment of the image on mobile, change the setting of the view in Rev Slider then move the placement of the image closer to the top:

In case that you want to change the height of the slider on mobile, you can change it in the slider settings:

Hope this helps.

Thank you. I did not manage to make it work though.

  1. I changed the dimension of the mobile layer, but it doesn’t seem to apply… (see below)
  2. The scroll problem is still there (the option was already deactivated)

Hi Antoine,

Please keep in mind that you set up your text element and slider revolution in separate 1/2 columns. In mobiles the layout of the column is stacked, that is why you have that text and slider layout in mobile. If you need the text to always part of the slider, you need to write/add the text on the slider itself and have only one column on your set up.

Slider Revolution Documentation

I’ve checked your page in an actual phone and I don’t get the scroll problem, would you mind to clarify on how we can replicate that, and what devices and browser you tested it?


Thank you for the clarification. I doesn’t really help me though.

1, Yes, I understood that “In mobiles the layout of the column is stacked”. The problem is just that I did not manage to get the dimensions of the slide to display as it is on the WP Admin. No idea why… (You can see it on my previous post)
2, I still have the scroll problem ON the slide. I tested on an android using Chrome.

Hi Antoine,

In that case, please provide us login credentials in a secure note so we can take a closer look.


Here it is. Thanks.

Hello @Lecoqdigital,

I have logged in and I was able to resolve the issue. I turn off the “Touch Enabled” option.

Please check your site now.

Thank you very much. I’ll now be able to solve the similar problems I have on other pages. One problem remains though, I am still not able to get the slider to display in the right dimention on mobile, despite the setting I’ve done in the WP admin (see below). How can I fix it?

Hello @Lecoqdigital,

You are only checking the preview and not the actual size of your slider grid layout. Please go to the Slider Settings > Slider Layout and check the size for smaller screens.

Hope this helps.

I did change it already, but it’s not working. I have no idea what I am doing wrong.

Hello @Lecoqdigital,

The preview is exactly the same as your custom grid.

The live view of the page does not follow the slider widths because you have set it as fullscreen. Please edit your slider and select “Auto” or “Fullwidth” as your Slider Layout.

Hope this helps. Please let us know how it goes.

Thank you very much for the great support!

You’re welcome!
We’re glad we were able to help you out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.