Page Unresponsive while editing content with Pro page builder

Hello Joy,

Thanks for writing in! Unresponsive pages could mean that the PHP time out limit has been reached or the PHP memory limit has been exhausted. ​We recommend that you increase your memory allocated to PHP. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line
/*That's all, stop editing! Happy Blogging. */

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288

We would loved to know if this has work for you. Thank you.

Hello @ruenel

I tried the code you sent. PHP memory limit is 512M but still, there is some issue with page builder. When I edit content page becomes unresponsive and throws a lot of errors in the console.

Thank you

Hello Joy,

I have logged in and I edited your page. I could not replicate any issues at all.

You might have resolved the issue already. Have you deactivated any plugins recently?

Kindly let us know.

Hello @ruenel

I can still replicate the issue. When I edit this post “Heather DelCarpini” from Executive Team custom post type, then I am not able to save, even click is not working. Pro page builder page becomes unresponsive.

You can try to edit this post “Heather DelCarpini” from Executive Team custom post type. Currently, I set it to draft as I cannot change the content.

Thank you

Hello Joy,

I have checked your site and there are quite a lot of plugins active on the site. Also, when I am on Cornerstone editing initially works but after a while, the page freezes and it generates countless errors. It is possible that a third party plugin is causing this so please try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes.

Hello @jade

I have tied troubleshooting by deactivating plugins. But that didn’t work. I am noticing this issue after I updated a theme before a week. Could you please look into what is causing this issue?

Thank you

Hi Joy,

I went to your website and did some tests and it seems the problem occurs as soon as I want to save the page, and it doesn’t matter if it is a custom post type or not it causes the browser window to crash.

I went to Pro > Status and found out the PHP Memory Limit is still 256 and is not 512. Please contact WP Engine and ask them to increase that from their side.

Meanwhile, if the problem persists we need your permission to do more tests and that might cause problems on the front end of the website. So I want to make sure that you have another live version and this is not the live version of your website, if it is, please create a staging version for our test. You can ask WP Engine to do that for you.

Thank you.

Hi @christopher

I checked with wpmudev support, and the PHP memory limit is 512. at Tools > Site Health > Info > Server. But it is 256 at Pro > Status.

Page builder freezes when I edit content and also media upload is not working inside page builder.

I have created a staging site. So you can test the staging site, details are in a secure note.

Thank you.

Hello Joy,

I have edited the mentioned page and I did not encounter any issues. I was able to upload an image as well.

One thing I noticed is that the Folders plugin is generating a JS error. You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Please let us know how it goes.

Hello @ruenel , @christopher , @jade

Thank you all for looking into this issue. I have tried changing the child to the parent theme, I tried deactivating all plugins but still, I can replicate the page builder freezing issue. I tried troubleshooting with the web host wpmudev. But it seems the issue is with the theme. Could you please look into the site again?

I tried to edit this post on the staging site. All plugins are deactivated on the staging site.
https://glytecsystems.staging.wpmudev.host/news/test-post/

In the console, it generates thousands of error and that makes the page unresponsive. It seems there is an issue with theme JS file.

https://glytecsystems.staging.wpmudev.host/wp-content/themes/pro/cornerstone/assets/dist-app/js/cs.2f77946.js
https://glytecsystems.staging.wpmudev.host/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0

Thank you.

Hello Joy,

I have re installed your WP core. I went ahead and edited the page. I am no longer seeing any JS errors. Please clear your browser caches or use private browsing mode and test your page again.

Hope this helps. Kindly let us know.

Hello @ruenel

I can still replicate the issue, and page builder freezes and it generates thousands of JS errors. I tried all below things but still there is an issue with the page builder and media upload from the page builder.

Deactivated all plugins
Activated Parent Pro theme
Re-installed the browser and also checked in Incognito mode

Please have a look again into the issue.

Thank you.

Hi Joy,

I was able to do edits and save changes on this test posts without any issue (browser did not freeze or crash, no error when adding media.).

Although I get this error on the console,

  • image

It looks to be a JS conflict, since most of your plugins are already deactivated I did test your custom JS in Theme Options by removing all of it temporarily, and that get rid of that JS error. So you might need to do some audits on those custom scripts. However, when I add back the said JS codes the error did not return any more.

If the issue still happening on your end, please try deactivating all the add-ons on your browser, also try deactivating your anti-virus/firewall temporarily and see if that resolves the issue.

The fact that I can edit that test posts with no issue on my end, that means there is no issue with the PRO theme.

Let us know how it goes,
Cheers!

Hello @friech

I can still replicate the issue. I tried to troubleshoot with web host WPMUDEV and they can also replicate the issue. Please check the site again.

The Pro page builder is throwing too many errors in like 10 seconds it throws like 30-40k errors or more

Thank you

Hi Joy,

Would you please kindly ask the hosting provider to give you a zip of your website files and the database export? Then please upload the zip file and database export to a sharing service such as Dropbox and share the link via Secure Note?

I want to test the website on my local machine and another hosting service to see if it fixes the issue.

Thank you.

Hi @christopher

The site is very big around 15 GB. You can download the full site from the below link.

There are videos in the upload folder which are consuming lot of space. If you don’t need an upload folder then you just download latest backup from UpdraftPlus backup (themes, plugins, and database). You can replace these folder/files to the latest wordpress zip file.

Thank you

Hey Joy,

The result is a bit different on my end. The WordPress built-in post and page post types works on my end. It’s the Executive Team custom post type that is having an issue. I get the same errors you had.

Specifically, the freezing only happens when I start working on any text element. It boils down to the Font Manager. If I disable it in Theme Options > Typography, the Executive Team posts works. I could edit and save. You can see that I have edited the post in the secure note.

If I enable the Font Manager, I needed to set the Heading Letter Spacing to more than 0 which is the default.

That said behavior could be a conflict with your web host’s server setup. I tested the same CPT setup as yours in my test site and I didn’t encounter this issue. Please try copying your site to a different web host with a completely different setup. Try a web host that uses Apache for instance. Your host now uses nginx. There’s nothing wrong with nginx. It could just be the server configuration which is outside our control.

This is at least my investigation. I ran out of time to do more test so my colleagues will be continuing in case I’m not around.

Hope that investigation helps.

@christian

Thank you for the investigation.

I am not able to edit anything from the Pro Page Builder.

I have activated parent theme, deactivated all plugins, contacted wpmudev web host, also tested site on Bluehost. I tried all possible ways to troubleshoot this issue. But still, there is an issue with the page builder.

I noticed that two scripts may be causing issues. In the console, it generates thousands of errors and that makes the page unresponsive. It seems there is an issue with the theme JS file and maybe it conflicts with wordpress js files. Please check this if it is helpful.

https://glytecsystems.staging.wpmudev.host/wp-content/themes/pro/cornerstone/assets/dist-app/js/cs.2f77946.js
https://glytecsystems.staging.wpmudev.host/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0

Thank you

Hi @joyefron,

I’ve been testing on your site, and so far I’ve encountered this error:

It could consistently be reproduced by adding a new section, clicking a column layout, then trying to drag in an element. The element would still be added, but it would not show the highlight styling to know where it would be dropped.

I was able to correct this on the staging site (I’ve not made changes in production) by reworking your Global Javascript (in Theme Options) to not call jQuery.noConflict();. Instead, to access jQuery as $ it’s better to wrap your code in a self executing anonymous function like this:

(function($){
  // $ is jQuery
})(jQuery);

This is another way that is often more useful because you can wait until jQuery is ready first:

jQuery(function($){
  // $ is jQuery, and we wait until the document is ready first
})

All that said, I’ve not encountered the other errors mentioned here, particularly the one that loops thousands of times. Is there a way you’ve observed to trigger that consistently?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.