One Page Navigation does not work

Hi there,

unfortunately i have problems getting the one page navigation working.
I followed all steps in the documentation carefully, but it does not do what it´s supposed to do.
I am using Pro/Integrity, have activated one page navigation on the page and gave an unique ID to each of my 3 sections and also did not forget the # in the links in the main menu.

Do you have an idea, where the bug is sitting?

Thank you for your help!


Hi Bernhard,

Thanks for writing in! To assist you with this issue, we’ll first need you to provide us with your URL. This is to ensure that we can provide you with a tailored answer to your situation. Once you have provided us with your URL, we will be happy to assist you with everything.

Thank you.

Hi Jade,

Thanks for your answer!
The URL is
Do you need the Admin credentials as well?


Hi Bernhard,

You are using Ubermenu. This one page navigation setup will work on X theme default menu. Ubermenu has it’s own scrollto settings. Once Ubermenu plugin is enabled, default theme menu is replace by Ubermenu. Try disabling Ubermenu if you want that setup to work.

Hope this helps.

Hi Lely,

thanks for your support,

i disabled Ubermenu, but still does not want to work.
Nor if i use the default menu and neither if i assign it with the Pro-Header Builder.

i hope i don´t bother you to much.


Hi Bernhard,

IDs are case sensitive so if you used #kontakt on the menu you need to also use #kontakt and not #Kontakt on the content.

Hope it helps

That helped!

Thank you so much

You’re most welcome!

Hi there,

I have the same problem, my one page navigation in pro is not working. I made the sections, did the link and menu… however I am not sure if I should also do something in the headers.?

Please help.


Hi @harmoniqa,

Thanks for writing around! I checked your setup and you’ve given wrong links to menu items for example In you first menu Item I see the link http://#x-content-band-1 which is not right, please use #x-content-band-1 only, do this for all the menu items to fix the issue. Make sure you’ve a section with the ID x-content-band-1 otherwise it won’t work. Please refer to the following documentation as well