Not show Cornerstone in page and post

The tab to edit or create with Cornerstone is not displayed …

WP: 4.9.7
X theme: 6.2.1
X theme Child: 1.0.0
Cornerstone: 3.2.1

Hey Mauro,

It could have been disabled in Permissions. Please check in X > Settings > Permissions if Cornerstone is enabled for your user role.


1 Like

Thank you very much, it works!

I have another query … is it possible to not show the menu option on the left and the option of the X header to a specific role? Only the administrator sees it!

Hello @gbg4,

Thanks for updating the thread.

Yes, in permission manager you have the option not to display X menu to users other then administrator. From X > Settings > Permissions toggle Editor tab and in that Turn Off Theme Options. Here is a screencast.

For more information on permissions manager, please take a look at changelog and Knowledge-base article.


I have done what you have told me but keep showing the “X” options all and remove the permissions.

For Pronautic - Pedidos not hidden X options!

Hello @gbg4,

Thanks for updating. :slight_smile:

I am a bit confused by your reply but have you made the permission changes in Editor tabs? Looking at the screenshot you might have made the changes for Administrator role.


Good Morning,

I have installed the “User Role Editor” plugin and I have created two new roles

  • Pronautic - Orders
  • Pronautic - Customers

both are copies of the subscriber role adding some new capabilities.

These two roles are what I want you not to see the “X” options of the menu on the left and the header!

I have done the steps you have told me but they continue to show …

Hey Mauro,

Looks like your customer user roles have some capability that a higher user role has that is why the menus are still showing up. Regretfully, since this involves third party plugin functionality and custom user role, we could not provide support for this.

Thank you for understanding.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.