No WooCommerce on Ethos

Hi There,
I am having a strange issue. I am trying to use the ethos stack, but it makes all my WooCommerce stuff disappear. Whether on the homepage as a shortcode or the store pages. I tried to create a new site with no plugins or data and it happens every time i switch the stack to Ethos… Please help

The site is at and the second site i just created site is at


Hey Andrew,

Thanks for writing in! This is a known bug in the latest release in X and Pro theme when using a masonry layout. While the patch update is not yet release, we can resolve this by doing the following steps:
1] Using Notepad or TextEdit or Sublime Text or any text editor, please create a new file in your local machine.
2] Insert the following code into that new file


// =============================================================================
// -----------------------------------------------------------------------------
// Isotope script call for index output.
// =============================================================================

$is_rtl = is_rtl();



  jQuery(document).ready(function($) {

    <?php if ( $is_rtl ) : ?>

      $.xIsotope.prototype._positionAbs = function( x, y ) {
        return { right: x, top: y };

    <?php endif; ?>

    var $container = $('#x-iso-container');

    $container.before('<span id="x-isotope-loading"><span>');

    $(window).load(function() {
        itemSelector   : '.x-iso-container > .hentry',
        resizable      : true,
        filter         : '*',
        <?php if ( $is_rtl ) : ?>
          transformsEnabled : false,
        <?php endif; ?>
        containerStyle : {
          overflow : 'hidden',
          position : 'relative'
      $('#x-iso-container > .hentry').each(function(i) {
        $(this).delay(i * 150).animate({'opacity' : 1}, 500);

    $(window).xsmartresize(function() {
      $container.xIsotope({  });



3] Save the file named as _script-isotope-index.php
4] Upload this file to your server in the child theme’s folder wp-content/themes/x-child/framework/views/

If the path does not exist in your child theme, you will have to create the directories within your child theme so that you will have the correct directory path.

Please let us know how it goes.

I just did that, but nothing changed…

Hi Andrew,

I’ve checked the Orbit site and the issue appears to be purely CSS related along with template related, the template provided by RueNel should get you partly there. Then there’s an Overflow hidden that’s stopping the products from showing, as the products aren’t in the correct positioning (see screenshot of what it looks like when I remove the overflow hidden property).

Can you post some WP Admin Login details for the Orbit site in a secure note please.


I just sent a secure note…

Hey there,

The products are loaded in your shop page and also the product in your home page but they don’t show up because of the CSS code in Ethos. I see you have not updated X and Cornerstone yet but you’re using the latest WooCommerce version (3.1.2 as of this writing). This could be a version conflict. Please ensure everything is up to date according to our version compatiblity list, clear all caches including browser cache then check again.

I tested using the latest X, Cornerstone and WooCommerce in my test site and the products are showing up.


Hey Christian,
No luck. I updated X and Cornerstone and cleared all caches, but no change.
I even created a new site with the latest versions as well and every time I switch to the Ethos theme the woocommerce stuff disappears.


The products are not showing because of this code.

.entry-featured {
     display: none !important; 

Kindly remove it in Appearance > Customize > Custom > Edit Global CSS

that worked…thanks so much…I forgot about that customization I made…

You’re welcome.