No Featured Image on Page

I found a similar support question and answer for no image appearing on page.
I cleared cached yet the image does not appear. I changed to another image, however it does not appear.


Hi Robert,

Depending on the Page Template set to the page, the featured image may or may not display.

If you have select a Blank templates, the featured image will not be displayed as blank templates are essentially blank pages and you add the page’s content from scratch aside from the header and footer area.

Try using the default template or the layout templates.

Hope this helps.

Hey Robert,

The image in your page actually exist but it’s hidden by this custom CSS.

div.entry-thumb {
    display: none;

Please remove the custom CSS. If it’s not in Theme Options > CSS, it’s most probably in Appearance > Customize > Additional CSS.

By the way, removing custom code is one of the common solutions. If you’re interested in solving issues fast, you can copy this checklist.

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. If you’re using a caching plugin, clear all caches including browser cache then deactivate your caching plugin and other optimization plugins.

  3. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  4. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  5. If you’re using a child theme, switch to the parent theme. This will tell you if a custom template or function is causing the issue.

  6. Remove custom HTML, CSS and Javascript where you have added them.

  7. Reset your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button.

  8. Contact your host to increase your allocated memory or do it yourself by adding this code in your wp-config.php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );


You’re welcome, Robert. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.