My footer becomes a sidebar every time I update my theme

Hi, every time I update the Xtheme, the footer becomes a sidebar.

Can you take a look? I can give you my credentials to enter the dashboard and a ftp access.

Hi There,

Please audit those problematic page content and make sure there is no unclosed <div> tag (or any unclosed tag).

Unclosed tag may have happen when you insert a custom html code on the page. So please review each of your posts and pages.

If it still doesn’t work, would you mind providing us with login credentials(by clicking on the Secure Note button at the bottom) so we can take a closer look? To do this, you can make a post with the following info:

  • Link to your site
  • WordPress Admin username / password


Here are my credentials :

Thank you for your support.

Hi There,

Could you please tell us which page the footer becomes sidebar?

I went through your website but couldn’t find it.

Thank you.

It is when I update the X theme. You have to update the theme and the footer will go on the side in the whole website. If you can’t find the issue, you will have to let me know so I can revert this action.

Hi @ProductionMD1986

We can’t update the theme on your live website, first you need to take a full backup of your website, then transfer it to a staging server where we can investigate this issue.

Once you have this staging server ready, please provide us with its WordPress and FTP login details in a Secure Note.

You might find this plugin helpful in this case:


Hello, I updated the theme myself…and sure enough, same problem happens again. It doesn’t cause a major problem, people can still access the site, but the footer is now on the side. I temporally cleared the footer (no widgets) so the problem appears smaller.

Do you have any idea of what’s causing this?

Thanks for your help.

I see you’re using the latest version of X but not Cornerstone. This could be a result of version incompatibility. Please update Cornerstone to the latest version first then check if the issue persists.


Hello, I updated Cornerstone and…yes, sadly it persists…

Hi There,

Please confirm if this is the correct URL of the site I can not seem to access it, please check.

If the issue is only happening to a specific page, please point us to that page, so we can check the content of that page.

Remember to clear all caches (plugin, server-side, CDN, and browser’s cache) after updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Also, worth mentioning that if you have a modification done on the child theme. Please try switching to parent X theme and see if the issue resolves. If it does, then you know its something on your child theme is causing it.


Spot on! It is the child theme with a combination of the new version of the X theme. It was working fine with the old version. I have to admit I didn’t program this site, but I have to find what’s wrong with the footer, since we want to keep updating the theme in the future.

Could you take a look on the child theme? It would be much appreciated.

P.S.: Sorry for the the site, it was down for a few hours yesterday and today. It is working now.

Hello @ProductionMD1986,

Thanks for updating the thread.

Can you please share FTP credentials in secure note? I tried to navigate through the codes in your website and the editor is behaving quite weirdly and won’t allow me to navigate through the codes. Please share FTP details (host/username/password) for us to take a closer look.


here are the FTP credentials :

Thanks again for your help.

Hi There,

Thank you for the FTP credentials, but I can not do any modification with that account, it says 550 Permission denied

Please do this: Setup a new Child Theme, activate that new child theme. Moved your customization from old child theme to new one template at a time, then constantly checking on the front-end and see which custom template that causing the footer issue.

Let us know how it goes,

Hi, I used Dreamweaver for a test with those credentials (but I had to connect using passive FTP and IPV6 Transfer Mode to be able to make any change in the files) and it worked.

Is it possible for you to look once again? It’ll be much appreciated.

Thank you.

Hello @ProductionMD1986,

Thanks for confirming the FTP login details.

I checked your theme files and it seems that the issue is coming from _footer.php under /wp-content/themes/alct/framework/views/global. I deleted the code in _footer.php and then uploaded the file and layout got fixed. In that regards please take a re-look at the customisation you have made and make the necessary changes to fix the layout.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.