Modern Events Calendar not updating plugin or showing events

I cannot update the Modern Events Calendar to the latest version. I get an error each time. And now, the events won’t show. I get a not found page when I click on the event, even though it is properly listed in the calendar. I tried dumping the plugin and reloading, which brought the events back. But they disappeared again.

Hello @bonita63,

Thanks for writing in! I have checked the urls associated with your licenses. Since you are using SiteGround, could you please disable the supercacher in your hosting panel? The SuperCacher is developed by SiteGround exclusively for their customers. It increases the number of hits a site can handle and boosts the website loading speed. The SuperCacher includes 4 different caching options for maximum optimization of your websites. You can access the tool by clicking on the SuperCacher icon in your cPanel.

For more information about this, please check it out here:

Hope this helps.

Thank you. This is for a site I’m developing, not one of my own, but it’s also on Siteground. I’ll try disabling SuperCacher and see if that helps.

It looks like this might have been the issue. I’ve had a few times where I’ve deleted the plugin only to find the problem re-emerge, but I’ve tried turning off the Supercacher to the main domain as well as this subdomain. Hopefully, this resolves the issue. Thank you for the quick response!

Hey @bonita63,

Is your issue resolved already? Please clear your browser cache as well or use private browsing mode and check your site again.

Please let us know how it goes.

Thanks for checking in. I just got back from a road trip and checked it. It’s still showing the same issue, despite dumping my cache.


In that case, would you mind providing us your site url and wordpress admin login in Secure Note

Thank you. I’m just awaiting permission from the organization before I can give you access to the site. I should have something for you by tomorrow if not sooner. I appreciate the help.

You’re welcome! :slight_smile:

The site has not been published yet. Right now, it’s operating as a subdomain. If I delete the plugin and reload it, all the information for the events shows up for a while. Then, I get a 404 page after a while. Does that help in ascertaining the issue?

I tried deactivating your plugin and installing another event plugin, and I had the same issue. I will try deactivating other plugins in case one of the is causing a conflict.


Yes, please do a plugin test and let us know the result.


Hi Paul,

I decided not to test plugins, since it appears to be a configuration error of some kind. Siteground doesn’t think it’s a plugin issue. Please see secure note with login information to Siteground account. The site can be accessed from there.

Hello @bonita63,

We have logged in to your SIteGround. We still need your WordPress credentials because we need to check your WP settings. To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username

  • WordPress Password

    Thank you.

Hello @bonita63,

I have check your Events page. The left column is the calendar and the right column will display the events for that day.

No events for today:

Display Events for a day:

Hope this explains it briefly.

That is not the issue, Paul. When you click on the event, you get a 404 page. If I dump the plugin and reinstall, the event details show up when the event is clicked on. But, only for a short time. Then, it goes back to the 404 page.

Sorry, I meant RueNel.


Your events slug is in conflict with the url of your events page.

I tried to changed the events slug and it is no longer showing 404

You need to decide which one to change but they should not be the same.


Thank you, Paul. I changed the slug in the M.E. Calendar settings to “mec-events”. That seems to have resolved the issue.

I appreciate the help and the education as to what the issue was. Many thanks!

You’re welcome! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.