Missing text and icons in editor

Hi, I’m missing several icons and text in the edit bar for options like margin, padding link slides, type, border-radius graphic set up, etc. In the content as well in the header and footer edit mode. Fresh WordPress site, fresh Pro install and no problems on other sites running Pro. Can’t figure out what’s wrong.

It looks like font awesome is missing

Hello Brigit,

Thanks for writing in!

I couldn’t see the website as you have multiple licenses of Pro Theme. Please try out following solutions and let us know the outcome:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.
  3. Take a look at following tutorial and see how it goes.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Hi Brigit,

I see, in that case, please provide your admin login credentials in the secure note and we’ll check. It appears the icon are working fine on the front, I like to check what’s happening on the backend.


Information in the secure note

Hello @Brigit,

When I go to Pro > Settings, the User Permissions is missing. You may need to log in using the other WP user and check the settings. Meanwhile, since you are using SiteGround, could you please clear your site cache or disable the supercacher in your hosting panel? The SuperCacher is developed by SiteGround exclusively for their customers. It increases the number of hits a site can handle and boosts the website loading speed. The SuperCacher includes 4 different caching options for maximum optimization of your websites. You can access the tool by clicking on the SuperCacher icon in your cPanel.

For more information about this, please check it out here: https://www.siteground.com/tutorials/supercacher/supercacher_intro.htm

You need to clear your browser cache too or use the private browsing mode and test your site again.

Hope this helps.

Hi there, The User Permissions is also missing when I log in as both the other WP users. I’ve Tried to add a new user but no succes. I’ve disabled the SuperCacher and cleared my browser cache as well and I’ve tried different browsers.

Hey Brigit,

There might be some files in Pro that are corrupted. Can you please try reinstalling Pro manually?

You can download the latest Pro version from your dashboard: https://theme.co/apex/dashboard

Then login through FTP and go to wp-content/themes downloaded the current pro directory that is in there to serve as your backup then delete it after and upload the newly downloaded version of Pro from your Apex dashboard.

Let us know how it goes.

Installed new pro manually through FTP, still nothing. I also checked the other sites I have on Siteground / Pro, they all have user permissions. Since I have all my stuff on a test site I don’t mind to remove everything (except WP) if that helps?

Hey @Brigit,

The icons in the builder interface are not powered by Font Awesome but are SVGs. Someone or some software might have added something in the WordPress .htaccess file that prevents SVGs from being displayed.

With that said, please try resetting your htaccess file by renaming it to .htaccess-bak. Then in WP Admin Menu, go to Settings > Permalinks and just click the Save Changes button so that WordPress will generate a new htaccess.

If that doesn’t help, please remove everything including WordPress and do a clean install. You can also try copying the working sites for further testing.


Removed everything, clean install still no options for settings or SVGs

No clue what just happened, but all is good now, if you guys did this Thanks!!!

Hey @Brigit,

I just checked your site and the icons are displaying now. The cache might have factored in when you first checked.

Anyway, we’re glad the issue’s fixed.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.