Make Revolution Slider slide video start immediately

Hello Team,

I have looked through the support forum and read through ThemePunch documentation but I cannot find the solution.

I am building a new homepage for a site and at the top of the page, I have a Revolution Slider, which contains one slide with a Youtube video layer, several layers of text, and a button layer. When the page loads, you see the poster image and all of the other layers (text, button), but the video layer takes about 2-3 seconds to start playing. I really don’t like this. I want the video layer to start playing right away. I’ve set the slider settings and the individual slide to have 0 ms delay, so there should be no delay. Can you please take a look and let me know what’s going on here?

The page is titled Homepage Video New and is in draft form, so my credentials will follow. The Revolution Slider is called Home Sizzle.


Hi Rayna,

Thank you for reaching out to us. Regretfully there is no getting around this as heavy videos takes time to load in a website, you could try compressing your video and see if reduces the load time.

Alternatively you can use Background Video option (see screenshot)

Plesae see for more details.

Hope this helps!

Thank you so much for your response! I tried setting the video as a background video but it did not improve load time of the video.

For anyone who is reading this and is interested in how I added the Play Audio button to my slider, here’s a link:

Your alternative solution of trying to compress the video for faster load time does sound promising though. I assume this means uploading a smaller file size video to our Youtube account. If you mean something different, please let me know.

Thanks again!

Hey Rayna,

Yes, upload a smaller file size video to your YouTube account because smaller size videos will load faster and this will improve the initial loading of your video.


1 Like

Thank you! :blush:

You’re most welcome!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.