Links Won't Open in New Tab

Not sure what I did or what’s wrong, but suddenly links won’t open in new tabs.

Please see this page:
Scroll to the bottom, the section called Independent Research.

It’s in development so I don’t have a caching plugin running. I even tried on different browsers. I have the target set to blank. It seems to be an issue on other pages in this site as well.

WordPress, Pro, and plugins are all up to date.

Please help! Thank you!

Hey @OCcreates,

I just checked through the code inspector and none of the links have target blank assigned to them:

Are you able to successfully save the pages in the Pro builder? Also, kindly double check if you have enabled the Open Link in new tab option of the links:

If you are still not able to get the issue sorted, please provide us with the admin access to your site in a Secure Note:

Whaaaaat? How strange. Yes, I’m able to save the page in Pro builder. I just closed out and went back in and it’s still showing the target for me. See screen shot below.

Where is that Open Link in new tab option? I’ll add access in a secure note.

Thank you

Hello @OCcreates,

The text element has some restrictions in the html codes and characters that you may use. I would highly suggest that you use the Content Area or Classic Raw content element. These elements will prevent any changes and preserve your code when displayed on the front end.

Hope this helps. Please let us know how it goes.

I tried using a content area. It still will not open in a new tab. Anything else I can try?

Hello @OCcreates,

I have tested in my local testing servers and the target="_blank" gets displayed on the front end. I have tried this in the text element, content area, and the classic raw element.

I am guessing that a 3rd party plugin is causing this issue in your site. You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Please let us know how it goes.

Oh wow. It was a stupid plugin. Thank you so much for your help!

You’re most welcome, @OCcreates.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.