Language switcher shows language twice

Hi Hello,
my other ticket was closed, so I am writing again.

I have a problem with the language switching. It shows one language twice, but in brackets.

I will share you the login data, so you can have a look. Also attached a picture from the problem.Screenshot 2021-07-28 174026

Hello @l_eckardt,

Thanks for writing to us.

I tried to access your site dashboard but it requires a username and password for the popup to access the WordPress login page. I would request you to share the popup login details as well or disable the security plugin so that we can access your dashboard and check your settings.



I am sorry. I forgot that there is another login. I have given you the password in the security note

Hi Lutz,

Thank you for the credentials, this should not be happening because the Language name in the current language option on the Menu Language Switcher is already turned off.

This could be a plugin conflict, a caching-related issue, or a bug with WPLM. Please do the following:

If none of that works, please add this to Theme Options > CSS as a quick fix.

header span.wpml-ls-display {
    display: none;


Thanks, the code works!!

But now I have another problem. The language switcher is displayed in the wrong place.
Actually it is on the left side of the burger menu, but it is displayed on the right side. If you shrink the window in one place, it jumps to the right side.

Do you know what is the cause of this problem?

Hi Lutz,

I have checked the Header and found that the Language section is after the Burger Menu Desktop and that is why the Languages are shown after the burger menu. I would suggest you modify the Header and place the Language before the Burger Menu Desktop to show it to the right.

Hope it helps.

ahh perfekt thanks, i have not seen this.

Hi Lutz,

Glad that we are able to help you.


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.