Issue with menu

The main navigation menu on our website ( is acting very strangely — multiple highlighted colors, transparent drop-down menus instead of dark blue, etc.

If I go to appearance>>> menus, I get a “500 server error” message.


You can set your menu item colors in ubermenu setting. Please refer to the link below for your guide.

With regards to error 500, try to set wp_debug in your wp-config.php file to TRUE

define('WP_DEBUG', true);

Enabling WP_DEBUG will cause all PHP errors, notices and warnings to be displayed instead of just error 500.

It is most likely a memory limit issue so try to increase your memory limit to 512M

If that doesn’t help, please provide us your ftp and wordpress admin login in Secure Note


Hey Sean,

It looks like the Style Customizations options does not get loaded. This could be related to the error 500. At one point, Appearance > Menus successfully loaded but reloading the menus page mostly returns to error 500.

That error could be caused by the Menu Item Limit. For more details and a potential solution, please see

We also need that you test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.


I tried cutting/pasting each of these directives into my code snippets plug-in but all of them seem to return some type of syntax error:

The solution is to simply configure the max_input_vars so that it is large enough to handle the number of variables being sent by WordPress to save your menu.

If you have access to your php.ini, you can just add this directive (or change the value of the existing directive) to includes your max input variables:

max_input_vars = 3000;
If you don’t have access to this file (as with many shared hosts), you may need to contact your host to increase this limit.

Alternatively, you can try placing this in your .htaccess. This won’t work on some servers, so your mileage may vary.

php_value max_input_vars 3000
If you have a .user.ini file, you can add the following to override the default php.ini value

max_input_vars = 5000;

Hello Sean,

We are just glad that you have figured it out a way to correct the said issue.
Thanks for letting us know!

Best Regards.

My last reply didn’t say that I figured it out. It said the opposite. I tried cutting and pasting every line of code suggested in your article and got nothing but "syntax error messages. Read my last message

Hi Sean,

Most of hosting provided does not allow you to modify these variables that is why it returns an error.

Please contact your hosting provided and let them increase the max_input_vars and php memory imit for you.


I’ve increased the memory limit to 3000. Unfortunately, I’m still having an issue with Uber menu. it still shows all of our customized colors, fonts, etc. in the Uber setup menu but none of those are reflected in the actual page menu. It seems to be in just a plain default mode.

Hello Sean,

Your WordPress memory limit is still 40MB. You can check it out in the link I have added in the secure note.
You must increase it to at least 256MB. By default, WordPress will attempt to increase memory allocated to PHP to 40MB (code is at the beginning of /wp-includes/default-constants.php) for single site and 64MB for multisite, so the setting in wp-config.php should reflect something higher than 40MB or 64MB depending on your setup.

To increase your WP memory limit, please follow the instructions here:

Please let us know how it goes.

Memory limit is already at 256M–see screen shot below

Hi Sean,

I could see that the memory limit has been increased to 256MB but the issue still persists. Could you please increase it to 512MB?

If it still doesn’t help, please provide us with your FTP account so we can take a closer look.

Thank you.

*** Information edited ***

Hello Sean,

I was able to resolve your issue. It appears that it is because you have several number of menu items. What I did is that, with your WP Filemanager, I created a php.ini in your wp-admin folder.

I inserted this line in the php.ini:

max_input_vars = 3000;

Related links:

Please check your menus now.

The menu still doesn’t reflect any of the settings in Uber menus.

Hi Sean,

It must be the cache issue. I’ve changed the Dropdown Transitions to Shift Up and it’s working fine:

Please clear all the plugin/browser caches and check again.


Yes, the menu is “functioning” normally. However, if you look in the Uber menu settings, the menu colors are all updated with our blue/orange branding colors. None of those colors are reflected in the live menu. None of the font size/case selections are reflected in the live menu. The menu is simply black and white.

Also, my maximum file upload size used to be 64M but now now it’s 2M. It’s still listed as 64M at the host server level. how do I change that back to 64M?

Hi Sean,

Please resolve the WordPress memory limit issue first (because that is the reason why you can’t access the Appearance > Menu), please contact your hosting on how you can increase this effectively, as high as 512M because you’re using a lot a plugin (resources). See WooCommerce > Status you can see that is it still set as low as 40MB. Some hosting does not allow users to increase this by themselves (even if you do those tricks above), please ask your hosting to increase this for you.

The same thing for Max upload size, it is really set to only 2MB, Please contact your hosting, this might be the limitation of your hosting plan, you might need to upgrade your plan to get more resources.

We will tackle the UberMenu issue if it persists after we resolve the WordPress memory limit


this is not a server issue. As you can see from the screenshot, the server settings are already set to the proper limits. For example, file upload is set to 64M but on the website, it’s listed as 2M.

Hey Sean,

Regarding your Appearance > Menus, I’ve tested loading it 7 times and it loaded successfully for 4 times. it returned a fatal error for the rest of the time or specifically 3 times. During the times that it loaded, the menu page was very slow. This means that your server is struggling to handle a lot of menus even Ruenel increased the max_input_vars.

Regretfully, we can do nothing for your server’s limitation. Believe it or not, this one is an issue with your web host. But, it’s not really recommended to have lots of menu items in WordPress in general. Quality web hosts can handle many menus though.

Regarding the UberMenu style configurations not working in your site, it could be related to your web host or WordPress setup as the said options work fine in my test site. I couldn’t do testing in your live site as it will interrupt your site’s operation though so I can’t pin point the exact cause.

To test if your server is the only thing causing the issue, setup a staging site with fresh WordPress install and then only install our X and UberMenu in it and then add in menu items one by one until you experience lagging in the menu page. This will tell you how many menu items your server is able to handle.

If there’s no issue with the server test, add in the third party plugins you’re using in your live site to the staging site one by one. This will tell you if a third party plugin is causing the issue.

Thank you for your cooperation.