Issue with cornerstone not working

Hi Guys,

I tried installing a fresh theme x on the server, but i keep getting the error: “The preview could not load due to the iframe response being incomplete. This is most often related to a plugin conflict, or customizations introducing a PHP error.”

I tried updating the memory, changing the PHP version, turned on debug and changed the firewall settings but nothing seems to budge.

Hey @D_UI_F,

Welcome to our Support Forum and thanks for writing in.

Have you also tried deactivating all third-party plugins? If yes, please also try the rest of the troubleshooting procedures in our Common Issues article

If none of the suggested solutions work, please give us the following info in a Secure Note

  • WordPress Login URL
  • Admin level username and password
  • cPanel or FTP credentials


Hi Christian,

Yes, i tried it all. I attached the credentials in a secure note. Thanks for looking into this.

Hey @D_UI_F,

Thanks for providing the credentials. I tried increasing the post_max_size to see if it’ll fix the issue in your site but it remains 24M. Please contact your host to increase it to 100M or higher. Also increase upload_max_filesize to the same value or higher.

Also, please contact your web host to enable debugging so we could actually see the specific server errors. Please tell the web host to enable display_errors.

Though this isn’t the cause of the issue in your site, putting index.php in the permalinks can also cause preview errors so it’s best to remove it.

Let us know once the above suggestions has been done and we’ll continue checking.


Hi Christian,

I tried what you suggested but without any luck. I provided the Plesk inlog so you can check for yourself.

Please let me know if you have any other tips.

Hey @D_UI_F,

Thanks for providing Plesk access. The cause of the issue is your web host’s firewall. I deactivated it and Pro works. Please ask your web host to whitelist pro directory and also cornerstone-endpoint.

If that can’t be done or if the issue persists after that, regretfully, you’d need to move to a better web host. Pro works in most web hosts out of the box.

Hope that helps.

Hi Christian,

Thanks for helping out. I think this fixes the issue.

have a great weekend.

You’re most welcome, @D_UI_F.

Have a great weekend as well.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.