Issue when scrolling up using sticky header

Hi guys,

I just finished a website using Pro. All works fine.

For smaller screen sizes (max width 979px) I used a fixed header.

when scrolling down and back up, when reaching the top the content below the header “jumps” which I think is the amount of space taken by the sticky header.

is there a way to fix this?

Thank you

website is:

Hey @quinex,

Please try moving the sticky header above all your bars.

If that doesn’t work, please give us your site’s WordPress Login URL, Username and Password in a Secure Note so we could closely check the setup.



I sent you the secure note. Have you been able to look into it yet?


Hello @quinex,

Thanks for writing in!

Please be advised that the sticky bar with relative initial position will need the content of the page to hit the top of the browser window before the sticky header gets triggered. When you change the initial position to absolute, the jump could be prevented because by default, the sticky header is already triggered.

Please edit your header and see the difference by tweaking with the initial position.

That is true, bu then the content actually always is partially behind the sticky bar.

Is there a setting that can cope with that or is the only solution to give .main-full class a top margin for the height of the header?

Hello @quinex,

There’s no available settings for that. Yes, that would be the alternative. We have to add the space on top if you don’t want content behind the fixed bar.

That’s what I thought… may be nice to put on the future feature list to include a setting for that that can add the header space as margin-top to .main-full :slight_smile:

Noted, thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.